Every CVE Search/ Get API key

CVE-2017-16041

ikst Downloads Resources over HTTP

5.9 MediumFix available

ikst versions before 1.1.2 download resources over HTTP, which leaves it vulnerable to MITM attacks.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.65%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.9

ikst versions before 1.1.2 download resources over HTTP, which leaves it vulnerable to MITM attacks.

Record
CVE-2017-16041
CVSS 3.0
5.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-311, CWE-319
Updated
2026-11-02
CVE List No score

ikst versions before 1.1.2 download resources over HTTP, which leaves it vulnerable to MITM attacks.

Record
CVE-2017-16041
Weakness
CWE-311
Updated
2026-11-02
EUVDEUVD-2018-0329 No score

ikst versions before 1.1.2 download resources over HTTP, which leaves it vulnerable to MITM attacks.

Record
EUVD-2018-0329
Updated
2026-11-03
GitHub AdvisoriesGHSA-w23f-f3c5-r9qh No score

ikst Downloads Resources over HTTP

Affected versions of ikst insecurely download resources over HTTP.

In scenarios where an attacker has a privileged network position, they can modify or read such resources at will. While the exact severity of impact for a vulnerability like this is highly variable and depends on the behavior of the package itself, it ranges from being able to read sensitive information all the way up to and including remote code execution.

Recommendation

Upgrade to version 1.1.2 or greater.

Record
GHSA-w23f-f3c5-r9qh
Weakness
CWE-311
Updated
2026-11-02
OSVGHSA-w23f-f3c5-r9qh No score

ikst Downloads Resources over HTTP

Affected versions of ikst insecurely download resources over HTTP.

In scenarios where an attacker has a privileged network position, they can modify or read such resources at will. While the exact severity of impact for a vulnerability like this is highly variable and depends on the behavior of the package itself, it ranges from being able to read sensitive information all the way up to and including remote code execution.

Recommendation

Upgrade to version 1.1.2 or greater.

Record
GHSA-w23f-f3c5-r9qh
Weakness
CWE-311
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ikst
npm
before 1.1.2
1.1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-16041 is a medium vulnerability (CVSS 5.9) in Ikst Project Ikst, published June 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.65%, the 51st percentile. Fixed in ikst 1.1.2.

References

MoveEnter Open