CVE-2015-7565
ember-source Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.
- Record
CVE-2015-7565- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.
- Record
CVE-2015-7565- Updated
- 2026-11-02
EUVDEUVD-2018-0409 No score
Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.
- Record
EUVD-2018-0409- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m3q7-rj8g-m457
6.1
ember-source Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.
- Record
GHSA-m3q7-rj8g-m457- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-m3q7-rj8g-m457
6.1
ember-source Cross-site Scripting vulnerability
Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.
- Record
GHSA-m3q7-rj8g-m457- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVCLSA-2026-1780447820 No score
TuxCare security update for ember-cli (1 CVE)
TuxCare rebuilt ember-cli to address 1 CVE. Fixed in 1.13.11-tuxcare.1.
- Record
CLSA-2026-1780447820- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ember-sourceRubyGems |
1.8.0 up to 1.11.4 | 1.11.4 |
ember-sourceRubyGems |
1.12.0 up to 1.12.2 | 1.12.2 |
ember-sourceRubyGems |
1.13.0 up to 1.13.12 | 1.13.12 |
ember-sourceRubyGems |
2.0.0 up to 2.0.3 | 2.0.3 |
ember-sourceRubyGems |
2.1.0 up to 2.1.2 | 2.1.2 |
ember-sourceRubyGems |
2.2.0 to 2.2.0 | 2.2.1 |
ember-cliTuxCare:npm |
1.13.11-tuxcare.0 up to 1.13.11-tuxcare.1, plus listed versions 1.13.11 |
1.13.11-tuxcare.1 |
ember-sourceRubyGems |
1.8.0 up to 1.11.4, plus listed versions 1.10.01.10.0.beta.11.10.0.beta.21.10.0.beta.31.10.0.beta.4 Show 22 moreShow less1.10.11.11.01.11.0.11.11.0.beta.11.11.0.beta.21.11.0.beta.2.11.11.0.beta.2.21.11.0.beta.31.11.0.beta.41.11.0.beta.51.11.11.11.31.11.3.11.8.11.9.01.9.0.alpha1.9.0.alpha.21.9.0.beta.11.9.0.beta.1.11.9.0.beta.31.9.0.beta.41.9.1 |
1.11.4 |
ember-sourceRubyGems |
1.12.0 up to 1.12.2, plus listed versions 1.12.1 |
1.12.2 |
ember-sourceRubyGems |
1.13.0 up to 1.13.12, plus listed versions 1.13.11.13.1.11.13.101.13.111.13.2 Show 8 moreShow less1.13.31.13.41.13.4.11.13.51.13.61.13.71.13.81.13.9 |
1.13.12 |
ember-sourceRubyGems |
2.0.0 up to 2.0.3, plus listed versions 2.0.2 |
2.0.3 |
ember-sourceRubyGems |
2.2.0 up to 2.2.1 | 2.2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-7565 is a medium vulnerability (CVSS 6.1) in Emberjs Ember.js, published April 13, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.82%, the 57th percentile. Fixed in ember-source 1.11.4.