Every CVE Search/ Get API key

CVE-2014-8144

Doorkeeper vulnerable to Cross-site Request Forgery

6.8 MediumFix available

Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote attackers to hijack the authentication of unspecified victims for requests that read a user OAuth authorization code via unknown vectors.

Exploit likelihood

0.65%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote attackers to hijack the authentication of unspecified victims for requests that read a user OAuth authorization code via unknown vectors.

Record
CVE-2014-8144
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote attackers to hijack the authentication of unspecified victims for requests that read a user OAuth authorization code via unknown vectors.

Record
CVE-2014-8144
Updated
2026-11-02
EUVDEUVD-2018-0441 No score

Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote attackers to hijack the authentication of unspecified victims for requests that read a user OAuth authorization code via unknown vectors.

Record
EUVD-2018-0441
Updated
2026-11-03
GitHub AdvisoriesGHSA-685w-vc84-wxcx No score

Doorkeeper vulnerable to Cross-site Request Forgery

Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote attackers to hijack the authentication of unspecified victims for requests that read a user OAuth authorization code via unknown vectors.

Record
GHSA-685w-vc84-wxcx
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-685w-vc84-wxcx No score

Doorkeeper vulnerable to Cross-site Request Forgery

Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote attackers to hijack the authentication of unspecified victims for requests that read a user OAuth authorization code via unknown vectors.

Record
GHSA-685w-vc84-wxcx
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
doorkeeper
RubyGems
before 1.4.1
1.4.1
doorkeeper
RubyGems
before 1.4.1, plus listed versions
0.1.00.1.10.2.00.3.00.3.1
Show 30 moreShow less
0.3.20.3.30.3.40.4.00.4.10.4.20.5.00.5.0.rc10.6.00.6.0.rc10.6.10.6.20.6.30.6.40.6.50.6.60.6.70.7.00.7.10.7.20.7.30.7.41.0.01.0.0.rc11.0.0.rc21.1.01.2.01.3.01.3.11.4.0
1.4.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-8144 is a medium vulnerability (CVSS 6.8) in Doorkeeper Project Doorkeeper, published December 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.65%, the 51st percentile. Fixed in doorkeeper 1.4.1.

References

MoveEnter Open