Every CVE Search/ Get API key

CVE-2018-11796

Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack

7.5 HighFix available

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

7.54%Up 3.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Record
CVE-2018-11796
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-611
Updated
2026-11-02
CVE List No score

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Record
CVE-2018-11796
Updated
2026-11-02
EUVDEUVD-2018-0614 No score

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Record
EUVD-2018-0614
Updated
2026-11-03
GitHub AdvisoriesGHSA-h8q5-g2cj-qr5h 7.5

Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Record
GHSA-h8q5-g2cj-qr5h
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-611
Updated
2026-11-02
OSV 7.5

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Record
CVE-2018-11796
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-h8q5-g2cj-qr5h 7.5

Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Record
GHSA-h8q5-g2cj-qr5h
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-611
Updated
2026-11-02
OSVUBUNTU-CVE-2018-11796 7.5

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Record
UBUNTU-CVE-2018-11796
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.tika:tika-core
Maven
0.1 up to 1.19.1
1.19.1
org.apache.tika:tika-core
Maven
0.1 up to 1.19.1, plus listed versions
0.100.40.50.60.7
Show 22 moreShow less
0.80.91.01.11.101.111.121.131.141.151.161.171.181.191.21.31.41.51.61.71.81.9
1.19.1
tika
Ubuntu:16.04:LTS
All versions, plus listed versions
1.5-21.5-31.5-41.5-4ubuntu0.1
None known
tika
Ubuntu:18.04:LTS
All versions, plus listed versions
1.5-5
None known
tika
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
1.22-11.22-1ubuntu0.1~esm11.22-1ubuntu0.1~esm21.22-1ubuntu0.1~esm3
None known
tika
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1.22-21.22-2ubuntu0.22.04.1~esm11.22-2+deb11u1build0.22.04.11.22-2+deb11u1ubuntu0.1~esm11.22-2+deb11u1ubuntu0.1~esm2
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-11796 is a high vulnerability (CVSS 7.5) in Apache Tika, published October 9, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.54%, the 94th percentile. Fixed in org.apache.tika:tika-core 1.19.1.

References

Show 4 moreShow less
MoveEnter Open