CVE-2018-18282
Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page
Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.
- Record
CVE-2018-18282- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.
- Record
CVE-2018-18282- Updated
- 2026-11-02
EUVDEUVD-2018-0672 No score
Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.
- Record
EUVD-2018-0672- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qw96-mm2g-c8m7
6.1
Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page
Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.
- Record
GHSA-qw96-mm2g-c8m7- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.
- Record
CVE-2018-18282- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-qw96-mm2g-c8m7
6.1
Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page
Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.
- Record
GHSA-qw96-mm2g-c8m7- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
nextnpm |
7.0.0 up to 7.0.2 | 7.0.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-18282 is a medium vulnerability (CVSS 6.1) in Zeit Next.js, published October 12, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.03%, the 63rd percentile. Fixed in next 7.0.2.