Every CVE Search/ Get API key

CVE-2016-5395

Apache Ranger allows remote authenticated administrators to inject arbitrary web script or HTML

4.8 MediumFix available

Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

2.10%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.8

Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.

Record
CVE-2016-5395
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.

Record
CVE-2016-5395
Updated
2026-11-02
EUVDEUVD-2018-0683 No score

Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.

Record
EUVD-2018-0683
Updated
2026-11-03
GitHub AdvisoriesGHSA-rf7q-xqm3-6923 4.8

Apache Ranger allows remote authenticated administrators to inject arbitrary web script or HTML

Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.

Record
GHSA-rf7q-xqm3-6923
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-rf7q-xqm3-6923 4.8

Apache Ranger allows remote authenticated administrators to inject arbitrary web script or HTML

Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.

Record
GHSA-rf7q-xqm3-6923
CVSS 3.0
4.8 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.ranger:ranger
Maven
before 0.6.1
0.6.1
org.apache.ranger:ranger
Maven
before 0.6.1, plus listed versions
0.6.0
0.6.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-5395 is a medium vulnerability (CVSS 4.8) in Apache Ranger, published September 26, 2016. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.10%, the 81st percentile. Fixed in org.apache.ranger:ranger 0.6.1.

References

MoveEnter Open