CVE-2017-11467
OrientDB vulnerable to Improper Privilage Management leading to arbitrary command injection
OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.
- Record
CVE-2017-11467- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-269
- Updated
- 2026-11-02
CVE List No score
OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.
- Record
CVE-2017-11467- Updated
- 2026-11-02
EUVDEUVD-2018-0716 No score
OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.
- Record
EUVD-2018-0716- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xm6r-4466-mr74
9.8
OrientDB vulnerable to Improper Privilage Management leading to arbitrary command injection
OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.
- Record
GHSA-xm6r-4466-mr74- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVGHSA-xm6r-4466-mr74
9.8
OrientDB vulnerable to Improper Privilage Management leading to arbitrary command injection
OrientDB through 2.2.22 does not enforce privilege requirements during "where" or "fetchplan" or "order by" use, which allows remote attackers to execute arbitrary OS commands via a crafted request.
- Record
GHSA-xm6r-4466-mr74- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
com.orientechnologies:orientdb-coreMaven |
before 2.2.23 | 2.2.23 |
com.orientechnologies:orientdb-coreMaven |
before 2.2.23, plus listed versions 1.01.0.11.0rc91.1.01.2.0 Show 45 moreShow less1.3.01.4.01.4.11.5.01.5.11.61.6.11.6.21.6.31.6.41.6.51.6.61.71.7-rc11.7-rc21.7.11.7.101.7.21.7.31.7.41.7.51.7.61.7.71.7.81.7.92.02.0-M12.0-M22.0-M32.0-rc12.0-rc22.0.12.0.102.0.112.0.122.0.132.0.142.0.152.0.162.0.172.0.182.0.22.0.32.0.42.0.5 |
2.2.23 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | OrientDB - Code Execution | 2017-07-13 |
| Metasploit | OrientDB 2.2.x Remote Code Execution | 2017-07-13 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-11467 is a critical vulnerability (CVSS 9.8) in Orientdb, published July 20, 2017. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 73.1%, the 99th percentile. Fixed in com.orientechnologies:orientdb-core 2.2.23.
References
Left out here: 62 versions. The JSON record has them.