Every CVE Search/ Get API key

CVE-2018-19661

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function...

6.5 MediumFix available

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

2.05%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Record
CVE-2018-19661
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Record
CVE-2018-19661
Updated
2026-11-02
EUVDEUVD-2018-11345 No score

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Record
EUVD-2018-11345
Updated
2026-11-03
GitHub AdvisoriesGHSA-xh77-pf23-wpw7 6.5

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function...

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Record
GHSA-xh77-pf23-wpw7
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2018-19661 6.5

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Record
ALPINE-CVE-2018-19661
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVBELL-CVE-2018-19661 6.5

CVE-2018-19661 does not affect BellSoft software

Record
BELL-CVE-2018-19661
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSV 6.5

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Record
CVE-2018-19661
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-19661 6.5

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Record
DEBIAN-CVE-2018-19661
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-19661 6.5

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service.

Record
UBUNTU-CVE-2018-19661
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2020-0197 No score

Updated libsndfile packages fix security vulnerabilities

Updated libsndfile packages fix security vulnerabilities:

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2ulaw_array in ulaw.c that will lead to a denial of service (CVE-2018-19661).

An issue was discovered in libsndfile 1.0.28. There is a buffer over-read in the function i2alaw_array in alaw.c that will lead to a denial of service (CVE-2018-19662).

Record
MGASA-2020-0197
Updated
2026-11-02
OSVUSN-4013-1 No score

libsndfile vulnerabilities

It was discovered that libsndfile incorrectly handled certain malformed files. A remote attacker could use this issue to cause libsndfile to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-4013-1
Updated
2026-11-02
OSVUSN-4704-1 No score

libsndfile vulnerabilities

It was discovered that libsndfile incorrectly handled certain malformed files. A remote attacker could use this issue to cause libsndfile to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2017-12562)

It was discovered that libsndfile incorrectly handled certain malformed files. A remote attacker could use this issue to cause libsndfile to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 ESM. (CVE-2017-14245, CVE-2017-14246, CVE-2017-14634, CVE-2017-16942, CVE-2017-6892, CVE-2018-13139, CVE-2018-19432, CVE-2018-19661, CVE-2018-19662, CVE-2018-19758, CVE-2019-3832)

Record
USN-4704-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsndfile
Alpine:v3.10
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.11
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.12
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.13
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.14
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.15
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.16
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.17
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.18
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.19
before 1.0.28-r6
1.0.28-r6
Show 20 moreShow less
Affected packages
PackageAffectedFixed
libsndfile
Alpine:v3.20
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.21
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.22
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.23
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.24
before 1.0.28-r6
1.0.28-r6
libsndfile
Alpine:v3.5
before 1.0.28-r4
1.0.28-r4
libsndfile
Alpine:v3.6
before 1.0.28-r4
1.0.28-r4
libsndfile
Alpine:v3.7
before 1.0.28-r4
1.0.28-r4
libsndfile
Alpine:v3.8
before 1.0.28-r5
1.0.28-r5
libsndfile
Alpine:v3.9
before 1.0.28-r6
1.0.28-r6
libsndfile
Debian:12
before 1.0.28-5
1.0.28-5
libsndfile
Debian:13
before 1.0.28-5
1.0.28-5
libsndfile
Debian:14
before 1.0.28-5
1.0.28-5
libsndfile
Debian:8
before 1.0.25-9.1+deb8u2, plus listed versions
1.0.25-9.11.0.25-9.1+deb8u1
1.0.25-9.1+deb8u2
libsndfile
Debian:9
before 1.0.27-3+deb9u1, plus listed versions
1.0.27-3
1.0.27-3+deb9u1
libsndfile
Mageia:7
before 1.0.28-8.2.mga7
1.0.28-8.2.mga7
libsndfile
Ubuntu:Pro:14.04:LTS
before 1.0.25-7ubuntu2.2+esm1, plus listed versions
1.0.25-7ubuntu11.0.25-7ubuntu21.0.25-7ubuntu2.11.0.25-7ubuntu2.2
1.0.25-7ubuntu2.2+esm1
libsndfile
Ubuntu:16.04:LTS
before 1.0.25-10ubuntu0.16.04.2, plus listed versions
1.0.25-9.11.0.25-101.0.25-10ubuntu0.16.04.1
1.0.25-10ubuntu0.16.04.2
libsndfile
Ubuntu:18.04:LTS
before 1.0.28-4ubuntu0.18.04.1, plus listed versions
1.0.28-4
1.0.28-4ubuntu0.18.04.1
libsndfile
Ubuntu:16.04:LTS
before 1.0.25-10ubuntu0.16.04.3, plus listed versions
1.0.25-9.11.0.25-101.0.25-10ubuntu0.16.04.11.0.25-10ubuntu0.16.04.2
1.0.25-10ubuntu0.16.04.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-19661 is a medium vulnerability (CVSS 6.5) in Libsndfile Project Libsndfile, published November 29, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.05%, the 81st percentile. Fixed in libsndfile 1.0.28-r6.

References

Show 22 moreShow less
MoveEnter Open