Every CVE Search/ Get API key

CVE-2018-19756

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8...

5.5 MediumFix available

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.68%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Record
CVE-2018-19756
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Record
CVE-2018-19756
Updated
2026-11-02
EUVDEUVD-2018-11440 No score

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Record
EUVD-2018-11440
Updated
2026-11-03
GitHub AdvisoriesGHSA-gp7j-cqhm-vf6q 5.5

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8...

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Record
GHSA-gp7j-cqhm-vf6q
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 5.5

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Record
CVE-2018-19756
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-19756 5.5

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Record
DEBIAN-CVE-2018-19756
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-19756 5.5

There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.

Record
UBUNTU-CVE-2018-19756
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsixel
Debian:12
before 1.8.2-2
1.8.2-2
libsixel
Debian:13
before 1.8.2-2
1.8.2-2
libsixel
Debian:14
before 1.8.2-2
1.8.2-2
libsixel
Ubuntu:16.04:LTS
All versions, plus listed versions
1.4.2-11.5.2-2
None known
libsixel
Ubuntu:18.04:LTS
All versions, plus listed versions
1.5.2-21.7.3-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-19756 is a medium vulnerability (CVSS 5.5) in Saitoha Libsixel, published November 30, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in libsixel 1.8.2-2.

References

MoveEnter Open