CVE-2018-19890
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c)...
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 2 case.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 2 case.
- Record
CVE-2018-19890- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 2 case.
- Record
CVE-2018-19890- Updated
- 2026-11-02
EUVDEUVD-2018-11564 No score
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 2 case.
- Record
EUVD-2018-11564- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-r3xr-2jwr-cwxx
5.5
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c)...
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 2 case.
- Record
GHSA-r3xr-2jwr-cwxx- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
5.5
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 2 case.
- Record
CVE-2018-19890- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-19890
5.5
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 2 case.
- Record
DEBIAN-CVE-2018-19890- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-19890
5.5
An invalid memory address dereference was discovered in the huffcode function (libfaac/huff2.c) in Freeware Advanced Audio Coder (FAAC) 1.29.9.2. The vulnerability causes a segmentation fault and application crash, which leads to denial of service in the book 2 case.
- Record
UBUNTU-CVE-2018-19890- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
faacDebian:12 |
before 1.30-1, plus listed versions 1.28+cvs20150510-11.28+cvs20151130-11.28-51.28-61.28-7 Show 8 moreShow less1.29+git20170704-11.29.2-11.29.3+git20170724-11.29.7.2-11.29.7.4-11.29.7.7-11.29.9.2-11.29.9.2-2 |
1.30-1 |
faacDebian:13 |
before 1.30-1, plus listed versions 1.28+cvs20150510-11.28+cvs20151130-11.28-51.28-61.28-7 Show 8 moreShow less1.29+git20170704-11.29.2-11.29.3+git20170724-11.29.7.2-11.29.7.4-11.29.7.7-11.29.9.2-11.29.9.2-2 |
1.30-1 |
faacDebian:14 |
before 1.30-1, plus listed versions 1.28+cvs20150510-11.28+cvs20151130-11.28-51.28-61.28-7 Show 8 moreShow less1.29+git20170704-11.29.2-11.29.3+git20170724-11.29.7.2-11.29.7.4-11.29.7.7-11.29.9.2-11.29.9.2-2 |
1.30-1 |
faacUbuntu:16.04:LTS |
All versions, plus listed versions 1.28+cvs20150510-11.28+cvs20151130-1 |
None known |
faacUbuntu:18.04:LTS |
All versions, plus listed versions 1.29.3+git20170724-11.29.7.7-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-19890 is a medium vulnerability (CVSS 5.5) in Audiocoding Freeware Advanced Audio Coder, published December 6, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 58th percentile. Fixed in faac 1.30-1.