CVE-2018-1079
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user...
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.7
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.
- Record
CVE-2018-1079- CVSS 3.0
- 8.7 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H - Weakness
- CWE-552
- Updated
- 2026-11-02
EUVDEUVD-2018-11731
8.7
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.
- Record
EUVD-2018-11731- CVSS 3.0
- 8.7 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wxjj-jh24-cx5f
6.5
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user...
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.
- Record
GHSA-wxjj-jh24-cx5f- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
NVD
8.7
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.
- Record
CVE-2018-1079- CVSS 3.0
- 8.7 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-552, CWE-22
- Updated
- 2026-11-02
OSV
6.5
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.
- Record
CVE-2018-1079- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-1079
6.5
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.
- Record
DEBIAN-CVE-2018-1079- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVRHSA-2018:1060
8.7
Red Hat Security Advisory: pcs security update
- Record
RHSA-2018:1060- CVSS 3.0
- 8.7 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-1079
6.5
pcs before version 0.9.164 and 0.10 is vulnerable to a privilege escalation via authorized user malicious REST call. The REST interface of the pcsd service did not properly sanitize the file name from the /remote/put_file query. If the /etc/booth directory exists, an authenticated attacker with write permissions could create or overwrite arbitrary files with arbitrary data outside of the /etc/booth directory, in the context of the pcsd process.
- Record
UBUNTU-CVE-2018-1079- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 3.0
- 8.7 High
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pcsDebian:12 |
before 0.9.164-1 | 0.9.164-1 |
pcsDebian:13 |
before 0.9.164-1 | 0.9.164-1 |
pcsDebian:14 |
before 0.9.164-1 | 0.9.164-1 |
pcsRed Hat:enterprise_linux:7::server |
before 0:0.9.162-5.el7_5.1 | 0:0.9.162-5.el7_5.1 |
pcs-debuginfoRed Hat:enterprise_linux:7::server |
before 0:0.9.162-5.el7_5.1 | 0:0.9.162-5.el7_5.1 |
pcs-snmpRed Hat:enterprise_linux:7::server |
before 0:0.9.162-5.el7_5.1 | 0:0.9.162-5.el7_5.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1079 is a high vulnerability (CVSS 8.7) in Redhat Pcs, published April 12, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. Fixed in pcs 0.9.164-1.
References
access.redhat.com/errata/RHSA-2018:1060
bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1079
nvd.nist.gov/vuln/detail/CVE-2018-1079
github.com/advisories/GHSA-wxjj-jh24-cx5f
security-tracker.debian.org/tracker/CVE-2018-1079
access.redhat.com/security/updates/classification
Show 14 moreShow less
bugzilla.redhat.com/show_bug.cgi?id=1534027
bugzilla.redhat.com/show_bug.cgi?id=1550243
bugzilla.redhat.com/show_bug.cgi?id=1557366
security.access.redhat.com/data/csaf/v2/advisories/2018/rhsa-2018_1060.json
access.redhat.com/security/cve/CVE-2018-1079
cve.org/CVERecord?id=CVE-2018-1079
access.redhat.com/security/cve/CVE-2018-1086
cve.org/CVERecord?id=CVE-2018-1086
nvd.nist.gov/vuln/detail/CVE-2018-1086
access.redhat.com/security/cve/CVE-2018-1000119
cve.org/CVERecord?id=CVE-2018-1000119
nvd.nist.gov/vuln/detail/CVE-2018-1000119
ubuntu.com/security/CVE-2018-1079
openwall.com/lists/oss-security/2018/04/09/2