Every CVE Search/ Get API key

CVE-2018-20230

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function...

7.8 HighFix available

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.81%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
CVE-2018-20230
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
CVE-2018-20230
Updated
2026-11-02
EUVDEUVD-2018-12796 No score

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
EUVD-2018-12796
Updated
2026-11-03
GitHub AdvisoriesGHSA-8jjx-c624-8pjg 7.8

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function...

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
GHSA-8jjx-c624-8pjg
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 7.8

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
CVE-2018-20230
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-20230 7.8

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
DEBIAN-CVE-2018-20230
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2018-20230 7.8

An issue was discovered in PSPP 1.2.0. There is a heap-based buffer overflow at the function read_bytes_internal in utilities/pspp-dump-sav.c, which allows attackers to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
UBUNTU-CVE-2018-20230
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2019:0198-1 No score

Security update for pspp, spread-sheet-widget

This update for pspp to version 1.2.0 fixes the following issues:

Security issue fixed:

  • CVE-2018-20230: Fixed a heap-based buffer overflow in read_bytes_internal function that could lead to denial-of-service (bsc#1120061).

Other bug fixes and changes:

  • Add upstream patch to avoid compiling with old Texinfo 4.13.
  • New experimental command SAVE DATA COLLECTION to save MDD files.
  • MTIME and YMDHMS variable formats now supported.
  • Spread sheet rendering now done via spread-sheet-widget.

This update introduces a new package called spread-sheet-widget as dependency.

Record
openSUSE-SU-2019:0198-1
Updated
2026-11-02
OSVopenSUSE-SU-2019:0240-1 No score

Security update for pspp, spread-sheet-widget

This update for pspp to version 1.2.0 fixes the following issues:

Security issue fixed:

  • CVE-2018-20230: Fixed a heap-based buffer overflow in read_bytes_internal function that could lead to denial-of-service (bsc#1120061).

Other bug fixes and changes:

  • Add upstream patch to avoid compiling with old Texinfo 4.13.
  • New experimental command SAVE DATA COLLECTION to save MDD files.
  • MTIME and YMDHMS variable formats now supported.
  • Spread sheet rendering now done via spread-sheet-widget.

This update introduces a new package called spread-sheet-widget as dependency.

This update was imported from the openSUSE:Leap:15.0:Update update project.

Record
openSUSE-SU-2019:0240-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11199-1 No score

pspp-1.4.1-2.3 on GA media

These are all security issues fixed in the pspp-1.4.1-2.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11199-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pspp
Debian:12
before 1.2.0-3
1.2.0-3
pspp
Debian:13
before 1.2.0-3
1.2.0-3
pspp
Debian:14
before 1.2.0-3
1.2.0-3
pspp
Ubuntu:16.04:LTS
All versions, plus listed versions
0.8.5-40.8.5-4build10.8.5-50.8.5-5build1
None known
pspp
Ubuntu:18.04:LTS
All versions, plus listed versions
1.0.1-1
None known
pspp
SUSE:Package Hub 15
before 1.2.0-bp150.3.3.1
1.2.0-bp150.3.3.1
spread-sheet-widget
SUSE:Package Hub 15
before 0.3-bp150.2.1
0.3-bp150.2.1
pspp
openSUSE:Tumbleweed
From an advisory covering 7 CVEs
before 1.4.1-2.3
1.4.1-2.3

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-20230 is a high vulnerability (CVSS 7.8) in Gnu Pspp, published December 19, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.81%, the 57th percentile. Fixed in pspp 1.2.0-3.

References

Show 10 moreShow less
MoveEnter Open