Every CVE Search/ Get API key

CVE-2018-3817

When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2...

6.5 Medium

When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2 could inadvertently log sensitive information.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.02%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2 could inadvertently log sensitive information.

Record
CVE-2018-3817
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-532, CWE-200
Updated
2026-11-02
CVE List No score

When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2 could inadvertently log sensitive information.

Record
CVE-2018-3817
Weakness
CWE-532
Updated
2026-11-02
EUVDEUVD-2018-15605 No score

When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2 could inadvertently log sensitive information.

Record
EUVD-2018-15605
Updated
2026-11-03
GitHub AdvisoriesGHSA-m5wv-852x-cj2g 6.5

When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2...

When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2 could inadvertently log sensitive information.

Record
GHSA-m5wv-852x-cj2g
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 6.5

When logging warnings regarding deprecated settings, Logstash before 5.6.6 and 6.x before 6.1.2 could inadvertently log sensitive information.

Record
CVE-2018-3817
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVSUSE-SU-2018:2317-1 No score

Security update for grafana, kafka, logstash, openstack-monasca-installer

This update for grafana, kafka, logstash, openstack-monasca-installer fixes the following issues:

Security issues fixed:

  • CVE-2018-12099: grafana: Fix XSS vulnerabilities in dashboard links (bsc#1096985).
  • CVE-2018-3817: logstash: Fix inadvertently logging of sensitive information (bsc#1090849).

Bug fixes:

  • bsc#1095603: Disable jmxremote debugging.
  • bsc#1097847: Make time series database schema setup conditional.
  • bsc#1094448: Set log rotation options.
  • bsc#1090336: Add complete set of elasticsearch performance tunables.
  • bsc#1101366: Fix build issues with s390x, ppc64le and aarch64.
  • Fix various spec errors affecting Leap 15 and Tumbleweed
Record
SUSE-SU-2018:2317-1
Updated
2026-11-02
OSVSUSE-SU-2018:2536-1 No score

Security update for grafana, kafka, logstash and monasca-installer

This update for grafana, kafka, logstash and monasca-installer fixes the following issues:

The following security issues have been fixed:

grafana:

  • CVE-2018-12099: Fix Cross-Site-Scripting (XSS) vulnerabilities in dashboard links. (bsc#1096985)

kafka:

  • CVE-2018-1288: Authenticated Kafka users may perform action reserved for the Broker via a manually created fetch request interfering with data replication, resulting in data loss. (bsc#1102920)

logstash:

  • CVE-2018-3817: Fix potential leak of sensitive data when logging warnings about deprecated options. (bsc#1090849)

Additionally, the following non-security issues have been fixed:

monasca-installer:

  • Add complete set of elasticsearch performance tunables.
  • Update to version Build_20180427_14.04 (bsc#1090192, bsc#1090343)
  • Fix bad elasticsearch-curator configuration. (bsc#1090192)
  • Enable bootstrap.memory_lock for Elasticsearch. (bsc#1090343)

logstash:

  • Declare Gemfile as config to prevent loss of installed plugins when updating.
  • Stop installing prebuilt jruby for non-x86.

kafka:

  • Update to version 0.10.2.2 (bsc#1102920, CVE-2018-1288)
  • Add noreplace directive for /etc/kafka/server.properties.
  • Reduce package ownership of tmpfiles.d to bare minium. (SLE12 SP2)
  • Set log rotation options. (bsc#1094448)
  • Disable jmxremote debugging. (bsc#1095603)
  • Increase open file limits. (bsc#1086909)
Record
SUSE-SU-2018:2536-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
grafana
SUSE:HPE Helion OpenStack 8
From an advisory covering 2 CVEs
before 4.5.1-4.3.1
4.5.1-4.3.1
kafka
SUSE:HPE Helion OpenStack 8
From an advisory covering 2 CVEs
before 0.9.0.1-5.3.1
0.9.0.1-5.3.1
logstash
SUSE:HPE Helion OpenStack 8
From an advisory covering 2 CVEs
before 2.4.1-5.4.1
2.4.1-5.4.1
openstack-monasca-installer
SUSE:HPE Helion OpenStack 8
From an advisory covering 2 CVEs
before 20180622_15.06-3.6.1
20180622_15.06-3.6.1
grafana
SUSE:OpenStack Cloud 8
From an advisory covering 2 CVEs
before 4.5.1-4.3.1
4.5.1-4.3.1
kafka
SUSE:OpenStack Cloud 8
From an advisory covering 2 CVEs
before 0.9.0.1-5.3.1
0.9.0.1-5.3.1
logstash
SUSE:OpenStack Cloud 8
From an advisory covering 2 CVEs
before 2.4.1-5.4.1
2.4.1-5.4.1
openstack-monasca-installer
SUSE:OpenStack Cloud 8
From an advisory covering 2 CVEs
before 20180622_15.06-3.6.1
20180622_15.06-3.6.1
grafana
SUSE:OpenStack Cloud Crowbar 8
From an advisory covering 2 CVEs
before 4.5.1-4.3.1
4.5.1-4.3.1
kafka
SUSE:OpenStack Cloud Crowbar 8
From an advisory covering 2 CVEs
before 0.9.0.1-5.3.1
0.9.0.1-5.3.1
Show 6 moreShow less
Affected packages
PackageAffectedFixed
logstash
SUSE:OpenStack Cloud Crowbar 8
From an advisory covering 2 CVEs
before 2.4.1-5.4.1
2.4.1-5.4.1
openstack-monasca-installer
SUSE:OpenStack Cloud Crowbar 8
From an advisory covering 2 CVEs
before 20180622_15.06-3.6.1
20180622_15.06-3.6.1
grafana
SUSE:OpenStack Cloud 7
From an advisory covering 3 CVEs
before 4.5.1-1.8.1
4.5.1-1.8.1
kafka
SUSE:OpenStack Cloud 7
From an advisory covering 3 CVEs
before 0.10.2.2-5.1
0.10.2.2-5.1
logstash
SUSE:OpenStack Cloud 7
From an advisory covering 3 CVEs
before 2.4.1-5.1
2.4.1-5.1
monasca-installer
SUSE:OpenStack Cloud 7
From an advisory covering 3 CVEs
before 20180608_12.47-9.1
20180608_12.47-9.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-3817 is a medium vulnerability (CVSS 6.5) in Elastic Logstash, published March 30, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. No source names a fixed version.

References

Show 13 moreShow less
MoveEnter Open