CVE-2018-1000098
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP...
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.
- Record
CVE-2018-1000098- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-190
- Updated
- 2026-11-02
CVE List No score
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.
- Record
CVE-2018-1000098- Updated
- 2026-11-02
EUVDEUVD-2018-1836 No score
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.
- Record
EUVD-2018-1836- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-chm5-gp28-v8xw
7.5
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP...
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.
- Record
GHSA-chm5-gp28-v8xw- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
7.5
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.
- Record
CVE-2018-1000098- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-1000098
7.5
Teluu PJSIP version 2.7.1 and earlier contains a Integer Overflow vulnerability in pjmedia SDP parsing that can result in Crash. This attack appear to be exploitable via Sending a specially crafted message. This vulnerability appears to have been fixed in 2.7.2.
- Record
UBUNTU-CVE-2018-1000098- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pjprojectDebian:9 From an advisory covering 4 CVEs |
before 2.5.5~dfsg-6+deb9u1, plus listed versions 2.5.5~dfsg-6 |
2.5.5~dfsg-6+deb9u1 |
pjprojectUbuntu:Pro:16.04:LTS |
before 2.1.0.0.ast20130823-1+deb8u1ubuntu0.1~esm1, plus listed versions 2.1.0.0.ast20130823-12.1.0.0.ast20130823-1+deb8u1build0.16.04.1 |
2.1.0.0.ast20130823-1+deb8u1ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-1000098 is a high vulnerability (CVSS 7.5) in Teluu Pjsip, published March 13, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.32%, the 88th percentile. Fixed in pjproject 2.1.0.0.ast20130823-1+deb8u1ubuntu0.1~esm1.
References
trac.pjsip.org/repos/milestone/release-2.7.2
trac.pjsip.org/repos/ticket/2093
debian.org/security/2018/dsa-4170
nvd.nist.gov/vuln/detail/CVE-2018-1000098
github.com/advisories/GHSA-chm5-gp28-v8xw
ubuntu.com/security/CVE-2018-1000098
downloads.asterisk.org/pub/security/AST-2018-002.html
cve.org/CVERecord?id=CVE-2018-1000098
ubuntu.com/security/notices/USN-8122-1