CVE-2018-8000
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer:...
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer::GetNextToken() in PdfTokenizer.cpp, a related issue to CVE-2017-5886. Remote attackers could leverage this vulnerability to cause a denial-of-service or potentially execute arbitrary code via a crafted pdf file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer::GetNextToken() in PdfTokenizer.cpp, a related issue to CVE-2017-5886. Remote attackers could leverage this vulnerability to cause a denial-of-service or potentially execute arbitrary code via a crafted pdf file.
- Record
CVE-2018-8000- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer::GetNextToken() in PdfTokenizer.cpp, a related issue to CVE-2017-5886. Remote attackers could leverage this vulnerability to cause a denial-of-service or potentially execute arbitrary code via a crafted pdf file.
- Record
CVE-2018-8000- Updated
- 2026-11-02
EUVDEUVD-2018-19712 No score
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer::GetNextToken() in PdfTokenizer.cpp, a related issue to CVE-2017-5886. Remote attackers could leverage this vulnerability to cause a denial-of-service or potentially execute arbitrary code via a crafted pdf file.
- Record
EUVD-2018-19712- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-68hv-95wx-r3jh
8.8
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer:...
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer::GetNextToken() in PdfTokenizer.cpp, a related issue to CVE-2017-5886. Remote attackers could leverage this vulnerability to cause a denial-of-service or potentially execute arbitrary code via a crafted pdf file.
- Record
GHSA-68hv-95wx-r3jh- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVALPINE-CVE-2018-8000
8.8
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer::GetNextToken() in PdfTokenizer.cpp, a related issue to CVE-2017-5886. Remote attackers could leverage this vulnerability to cause a denial-of-service or potentially execute arbitrary code via a crafted pdf file.
- Record
ALPINE-CVE-2018-8000- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
8.8
In PoDoFo 0.9.5, there exists a heap-based buffer overflow vulnerability in PoDoFo::PdfTokenizer::GetNextToken() in PdfTokenizer.cpp, a related issue to CVE-2017-5886. Remote attackers could leverage this vulnerability to cause a denial-of-service or potentially execute arbitrary code via a crafted pdf file.
- Record
CVE-2018-8000- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
podofoAlpine:v3.13 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.14 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.15 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.16 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.17 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.18 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.19 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.20 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.21 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.22 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.23 |
before 0.9.6-r0 | 0.9.6-r0 |
podofoAlpine:v3.24 |
before 0.9.6-r0 | 0.9.6-r0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, facts, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-8000 is a high vulnerability (CVSS 8.8) in Podofo Project Podofo, published March 9, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.82%, the 86th percentile. Fixed in podofo 0.9.6-r0.