CVE-2018-8099
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free...
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
- Record
CVE-2018-8099- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-415
- Updated
- 2026-11-02
CVE List No score
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
- Record
CVE-2018-8099- Updated
- 2026-11-02
EUVDEUVD-2018-19775 No score
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
- Record
EUVD-2018-19775- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mhmm-r9x5-v638
6.5
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free...
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
- Record
GHSA-mhmm-r9x5-v638- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-415
- Updated
- 2026-11-02
OSV
6.5
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
- Record
CVE-2018-8099- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-8099
6.5
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
- Record
DEBIAN-CVE-2018-8099- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-8099
6.5
Incorrect returning of an error code in the index.c:read_entry() function leads to a double free in libgit2 before v0.26.2, which allows an attacker to cause a denial of service via a crafted repository index file.
- Record
UBUNTU-CVE-2018-8099- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVSUSE-SU-2018:3440-1 No score
Security update for libgit2
This update for libgit2 fixes the following issues:
- CVE-2018-8099: Fixed possible denial of service attack via different vectors by not being able to differentiate between these status codes (bsc#1085256).
- CVE-2018-11235: With a crafted .gitmodules file, a malicious project can execute an arbitrary script on a machine that runs 'git clone --recurse-submodules' because submodule 'names' are obtained from this file, and then appended to $GIT_DIR/modules, leading to directory traversal with '../' in a name. Finally, post-checkout hooks from a submodule are executed, bypassing the intended design in which hooks are not obtained from a remote server. (bsc#1095219)
- CVE-2018-10887: It has been discovered that an unexpected sign extension in git_delta_apply function in delta.c file may have lead to an integer overflow which in turn leads to an out of bound read, allowing to read before the base object. An attacker could have used this flaw to leak memory addresses or cause a Denial of Service. (bsc#1100613)
- CVE-2018-10888: A missing check in git_delta_apply function in delta.c file, may lead to an out-of-bound read while reading a binary delta file. An attacker may use this flaw to cause a Denial of Service. (bsc#1100612)
- CVE-2018-15501: A remote attacker can send a crafted smart-protocol 'ng' packet that lacks a '\0' byte to trigger an out-of-bounds read that leads to DoS. (bsc#1104641)
- Record
SUSE-SU-2018:3440-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libgit2Debian:12 |
before 0.27.0+dfsg.1-0.6 | 0.27.0+dfsg.1-0.6 |
libgit2Debian:13 |
before 0.27.0+dfsg.1-0.6 | 0.27.0+dfsg.1-0.6 |
libgit2Debian:14 |
before 0.27.0+dfsg.1-0.6 | 0.27.0+dfsg.1-0.6 |
libgit2Debian:9 From an advisory covering 7 CVEs |
before 0.25.1+really0.24.6-1+deb9u1, plus listed versions 0.25.1+really0.24.6-1 |
0.25.1+really0.24.6-1+deb9u1 |
libgit2SUSE:Linux Enterprise Software Development Kit 12 SP3 From an advisory covering 5 CVEs |
before 0.24.1-7.6.1 | 0.24.1-7.6.1 |
libgit2SUSE:Manager Server 3.1 From an advisory covering 5 CVEs |
before 0.24.1-7.6.1 | 0.24.1-7.6.1 |
libgit2SUSE:Manager Server 3.2 From an advisory covering 5 CVEs |
before 0.24.1-7.6.1 | 0.24.1-7.6.1 |
libgit2Ubuntu:Pro:14.04:LTS |
before 0.19.0-2ubuntu0.4+esm2, plus listed versions 0.19.0-20.19.0-2ubuntu0.40.19.0-2ubuntu0.4+esm1 |
0.19.0-2ubuntu0.4+esm2 |
libgit2Ubuntu:Pro:16.04:LTS |
before 0.24.1-2ubuntu0.2+esm3, plus listed versions 0.22.2-20.23.1-10.24.1-20.24.1-2ubuntu0.20.24.1-2ubuntu0.2+esm10.24.1-2ubuntu0.2+esm2 |
0.24.1-2ubuntu0.2+esm3 |
libgit2Ubuntu:Pro:18.04:LTS |
before 0.26.0+dfsg.1-1.1ubuntu0.2+esm2, plus listed versions 0.25.1+really0.24.6-10.26.0+dfsg.1-1.10.26.0+dfsg.1-1.1build10.26.0+dfsg.1-1.1ubuntu0.20.26.0+dfsg.1-1.1ubuntu0.2+esm1 |
0.26.0+dfsg.1-1.1ubuntu0.2+esm2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-8099 is a medium vulnerability (CVSS 6.5) in Libgit2, published March 14, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.39%, the 72nd percentile. Fixed in libgit2 0.27.0+dfsg.1-0.6.
References
libgit2.github.com/security
github.com/libgit2/libgit2/commit/58a6fe94cb851f71214dbefac3f9bffee437d6fe
lists.debian.org/debian-lts-announce/2022/03/msg00031.html
nvd.nist.gov/vuln/detail/CVE-2018-8099
github.com/advisories/GHSA-mhmm-r9x5-v638
security-tracker.debian.org/tracker/CVE-2018-8099
Show 14 moreShow less
suse.com/support/update/announcement/2018/suse-su-20183440-1
bugzilla.suse.com/1085256
bugzilla.suse.com/1095219
bugzilla.suse.com/1100612
bugzilla.suse.com/1100613
bugzilla.suse.com/1104641
suse.com/security/cve/CVE-2018-10887
suse.com/security/cve/CVE-2018-10888
suse.com/security/cve/CVE-2018-11235
suse.com/security/cve/CVE-2018-15501
suse.com/security/cve/CVE-2018-8099
ubuntu.com/security/CVE-2018-8099
cve.org/CVERecord?id=CVE-2018-8099
ubuntu.com/security/notices/USN-8628-1