Every CVE Search/ Get API key

CVE-2018-10905

CloudForms Management Engine (cfme) is vulnerable to an improper security setting in the dRuby...

7.8 HighFix available

CloudForms Management Engine (cfme) is vulnerable to an improper security setting in the dRuby component of CloudForms. An attacker with access to an unprivileged local shell could use this flaw to execute commands as a high privileged user.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.47%Down 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.8

CloudForms Management Engine (cfme) is vulnerable to an improper security setting in the dRuby component of CloudForms. An attacker with access to an unprivileged local shell could use this flaw to execute commands as a high privileged user.

Record
CVE-2018-10905
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-284
Updated
2026-11-02
EUVDEUVD-2018-2961 7.8

CloudForms Management Engine (cfme) is vulnerable to an improper security setting in the dRuby component of CloudForms. An attacker with access to an unprivileged local shell could use this flaw to execute commands as a high privileged user.

Record
EUVD-2018-2961
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-jjjj-c3mp-q822 7.8

CloudForms Management Engine (cfme) is vulnerable to an improper security setting in the dRuby...

CloudForms Management Engine (cfme) is vulnerable to an improper security setting in the dRuby component of CloudForms. An attacker with access to an unprivileged local shell could use this flaw to execute commands as a high privileged user.

Record
GHSA-jjjj-c3mp-q822
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
NVD 7.8

CloudForms Management Engine (cfme) is vulnerable to an improper security setting in the dRuby component of CloudForms. An attacker with access to an unprivileged local shell could use this flaw to execute commands as a high privileged user.

Record
CVE-2018-10905
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-284, CWE-78
Updated
2026-11-02
OSVRHSA-2018:2561 7.8

Red Hat Security Advisory: CloudForms 4.6.4 security, bug fix, and enhancement update

Record
RHSA-2018:2561
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVRHSA-2018:2745 7.8

Red Hat Security Advisory: CloudForms 4.5.5 security, bug fix and enhancement update

Record
RHSA-2018:2745
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cfme
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
cfme-amazon-smartstate
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
cfme-appliance
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
cfme-appliance-common
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
cfme-appliance-debuginfo
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
cfme-appliance-tools
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
cfme-debuginfo
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
cfme-gemset
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
cfme-gemset-debuginfo
Red Hat:cloudforms_managementengine:5.9::el7
before 0:5.9.4.7-1.el7cf
0:5.9.4.7-1.el7cf
rh-postgresql95-postgresql-pglogical
Red Hat:cloudforms_managementengine:5.9::el7
before 0:2.1.0-4.el7cf
0:2.1.0-4.el7cf
Show 12 moreShow less
Affected packages
PackageAffectedFixed
rh-postgresql95-postgresql-pglogical-debuginfo
Red Hat:cloudforms_managementengine:5.9::el7
before 0:2.1.0-4.el7cf
0:2.1.0-4.el7cf
rh-ruby23-rubygem-redhat_access_cfme
Red Hat:cloudforms_managementengine:5.9::el7
before 0:2.0.3-1.el7cf
0:2.0.3-1.el7cf
rh-ruby23-rubygem-redhat_access_cfme-doc
Red Hat:cloudforms_managementengine:5.9::el7
before 0:2.0.3-1.el7cf
0:2.0.3-1.el7cf
ansible-tower-server
Red Hat:cloudforms_managementengine:5.8::el7
before 0:3.1.8-1.el7at
0:3.1.8-1.el7at
ansible-tower-setup
Red Hat:cloudforms_managementengine:5.8::el7
before 0:3.1.8-1.el7at
0:3.1.8-1.el7at
cfme
Red Hat:cloudforms_managementengine:5.8::el7
before 0:5.8.5.1-1.el7cf
0:5.8.5.1-1.el7cf
cfme-appliance
Red Hat:cloudforms_managementengine:5.8::el7
before 0:5.8.5.1-1.el7cf
0:5.8.5.1-1.el7cf
cfme-appliance-debuginfo
Red Hat:cloudforms_managementengine:5.8::el7
before 0:5.8.5.1-1.el7cf
0:5.8.5.1-1.el7cf
cfme-debuginfo
Red Hat:cloudforms_managementengine:5.8::el7
before 0:5.8.5.1-1.el7cf
0:5.8.5.1-1.el7cf
cfme-gemset
Red Hat:cloudforms_managementengine:5.8::el7
before 0:5.8.5.1-1.el7cf
0:5.8.5.1-1.el7cf
rh-postgresql95-postgresql-pglogical
Red Hat:cloudforms_managementengine:5.8::el7
before 0:1.2.1-2.el7cf
0:1.2.1-2.el7cf
rh-postgresql95-postgresql-pglogical-debuginfo
Red Hat:cloudforms_managementengine:5.8::el7
before 0:1.2.1-2.el7cf
0:1.2.1-2.el7cf

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-10905 is a high vulnerability (CVSS 7.8) in [unknown] Cfme, published July 24, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 41st percentile. Fixed in cfme 0:5.9.4.7-1.el7cf.

References

Show 82 moreShow less
MoveEnter Open