Every CVE Search/ Get API key

CVE-2018-11693

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was...

8.1 HighFix available

CVE-2018-11693 is a high vulnerability (CVSS 8.1) in Sass-lang Libsass, published June 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.35%, the 71st percentile. Fixed in libsass 3.5.4+20180621~c0a6cf3-1.

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

1.35%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.

Record
CVE-2018-11693
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.

Record
CVE-2018-11693
Updated
2026-11-02
EUVDEUVD-2018-3712 No score

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.

Record
EUVD-2018-3712
Updated
2026-11-03
GitHub AdvisoriesGHSA-rm2q-7xhq-fcm2 8.1

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was...

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.

Record
GHSA-rm2q-7xhq-fcm2
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 8.1

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.

Record
CVE-2018-11693
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-11693 8.1

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.

Record
DEBIAN-CVE-2018-11693
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-11693 8.1

An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::skip_over_scopes which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.

Record
UBUNTU-CVE-2018-11693
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUSN-4837-1 No score

libsass vulnerabilities

It was discovered that LibSass incorrectly handled certain specially crafted sass file. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Record
USN-4837-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsass
Debian:12
before 3.5.4+20180621~c0a6cf3-1
3.5.4+20180621~c0a6cf3-1
libsass
Debian:13
before 3.5.4+20180621~c0a6cf3-1
3.5.4+20180621~c0a6cf3-1
libsass
Debian:14
before 3.5.4+20180621~c0a6cf3-1
3.5.4+20180621~c0a6cf3-1
libsass
Ubuntu:16.04:LTS
All versions, plus listed versions
3.2.5-13.2.5-23.3.2-13.3.4-1
None known
libsass
Ubuntu:Pro:18.04:LTS
before 3.4.8-1ubuntu0.1~esm1, plus listed versions
3.4.3-13.4.6-13.4.8-1
3.4.8-1ubuntu0.1~esm1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 13 moreShow less
MoveEnter Open