Every CVE Search/ Get API key

CVE-2018-11695

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function...

8.8 HighFix available

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.63%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
CVE-2018-11695
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
CVE-2018-11695
Updated
2026-11-02
EUVDEUVD-2018-3714 No score

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
EUVD-2018-3714
Updated
2026-11-03
GitHub AdvisoriesGHSA-q72c-6p77-wj85 8.8

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function...

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
GHSA-q72c-6p77-wj85
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-476
Updated
2026-11-02
OSV 8.8

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
CVE-2018-11695
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-11695 8.8

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
DEBIAN-CVE-2018-11695
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-11695 8.8

An issue was discovered in LibSass <3.5.3. A NULL pointer dereference was found in the function Sass::Expand::operator which could be leveraged by an attacker to cause a denial of service (application crash) or possibly have unspecified other impact.

Record
UBUNTU-CVE-2018-11695
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-4837-1 No score

libsass vulnerabilities

It was discovered that LibSass incorrectly handled certain specially crafted sass file. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Record
USN-4837-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsass
Debian:12
before 3.5.4-1
3.5.4-1
libsass
Debian:13
before 3.5.4-1
3.5.4-1
libsass
Debian:14
before 3.5.4-1
3.5.4-1
libsass
Ubuntu:Pro:18.04:LTS
before 3.4.8-1ubuntu0.1~esm1, plus listed versions
3.4.3-13.4.6-13.4.8-1
3.4.8-1ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-11695 is a high vulnerability (CVSS 8.8) in Sass-lang Libsass, published June 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.63%, the 76th percentile. Fixed in libsass 3.5.4-1.

References

Show 15 moreShow less
MoveEnter Open