CVE-2018-11697
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was...
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
- Record
CVE-2018-11697- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
- Record
CVE-2018-11697- Updated
- 2026-11-02
EUVDEUVD-2018-3716 No score
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
- Record
EUVD-2018-3716- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7mp7-9qpg-63p9
8.1
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was...
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
- Record
GHSA-7mp7-9qpg-63p9- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
8.1
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
- Record
CVE-2018-11697- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-11697
8.1
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
- Record
DEBIAN-CVE-2018-11697- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-11697
8.1
An issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
- Record
UBUNTU-CVE-2018-11697- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVUSN-4837-1 No score
libsass vulnerabilities
It was discovered that LibSass incorrectly handled certain specially crafted sass file. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.
- Record
USN-4837-1- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-11697 is a high vulnerability (CVSS 8.1) in Sass-lang Libsass, published June 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in libsass 3.6.3-1.
References
github.com/sass/libsass/issues/2656
nvd.nist.gov/vuln/detail/CVE-2018-11697
github.com/advisories/GHSA-7mp7-9qpg-63p9
security-tracker.debian.org/tracker/CVE-2018-11697
ubuntu.com/security/CVE-2018-11697
ubuntu.com/security/notices/USN-4837-1
Show 13 moreShow less
cve.org/CVERecord?id=CVE-2018-11697
ubuntu.com/security/CVE-2018-11499
ubuntu.com/security/CVE-2018-11693
ubuntu.com/security/CVE-2018-11695
ubuntu.com/security/CVE-2018-11696
ubuntu.com/security/CVE-2018-11698
ubuntu.com/security/CVE-2018-19797
ubuntu.com/security/CVE-2018-19827
ubuntu.com/security/CVE-2018-19839
ubuntu.com/security/CVE-2018-20190
ubuntu.com/security/CVE-2019-6283
ubuntu.com/security/CVE-2019-6284
ubuntu.com/security/CVE-2019-6286