CVE-2018-12016
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a...
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
- Record
CVE-2018-12016- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
- Record
CVE-2018-12016- Updated
- 2026-11-02
EUVDEUVD-2018-4008 No score
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
- Record
EUVD-2018-4008- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5fwp-wgrw-hj8x
7.5
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a...
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
- Record
GHSA-5fwp-wgrw-hj8x- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
7.5
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
- Record
CVE-2018-12016- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-12016
7.5
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
- Record
DEBIAN-CVE-2018-12016- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-12016
7.5
libephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
- Record
UBUNTU-CVE-2018-12016- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
epiphany-browserDebian:12 |
before 3.28.3.1-1 | 3.28.3.1-1 |
epiphany-browserDebian:13 |
before 3.28.3.1-1 | 3.28.3.1-1 |
epiphany-browserDebian:14 |
before 3.28.3.1-1 | 3.28.3.1-1 |
epiphany-browserUbuntu:16.04:LTS |
All versions, plus listed versions 3.16.3-1ubuntu13.18.0-1ubuntu23.18.1-1ubuntu13.18.3-0ubuntu13.18.5-0ubuntu13.18.5-0ubuntu1.13.18.10-0ubuntu13.18.11-0ubuntu1 |
None known |
epiphany-browserUbuntu:18.04:LTS |
All versions, plus listed versions 3.26.1-1ubuntu13.26.1-1ubuntu23.26.1-1ubuntu43.26.5.1-1ubuntu13.27.90-1ubuntu1 Show 4 moreShow less3.28.0.1-1ubuntu13.28.1-1ubuntu13.28.5-0ubuntu13.28.6-0ubuntu1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-12016 is a high vulnerability (CVSS 7.5) in Gnome Epiphany, published June 7, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.87%, the 79th percentile. Fixed in epiphany-browser 3.28.3.1-1.