CVE-2018-12467
delete package via link exploit in open buildservice
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious request against projects having the OBS:InitializeDevelPackage attribute, a similar issue to CVE-2018-7689.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.0
delete package via link exploit in open buildservice
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious request against projects having the OBS:InitializeDevelPackage attribute, a similar issue to CVE-2018-7689.
- Record
CVE-2018-12467- CVSS 3.0
- 6.0 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:H - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2018-4437
6.0
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious request against projects having the OBS:InitializeDevelPackage attribute, a similar issue to CVE-2018-7689.
- Record
EUVD-2018-4437- CVSS 3.0
- 6.0 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-24pm-f3f4-m533
6.5
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious...
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious request against projects having the OBS:InitializeDevelPackage attribute, a similar issue to CVE-2018-7689.
- Record
GHSA-24pm-f3f4-m533- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-732
- Updated
- 2026-11-02
NVD
6.0
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious request against projects having the OBS:InitializeDevelPackage attribute, a similar issue to CVE-2018-7689.
- Record
CVE-2018-12467- CVSS 3.0
- 6.0 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:H - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.5 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:P - Weakness
- CWE-285, CWE-732
- Updated
- 2026-11-02
OSV
6.5
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious request against projects having the OBS:InitializeDevelPackage attribute, a similar issue to CVE-2018-7689.
- Record
CVE-2018-12467- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-12467
6.5
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious request against projects having the OBS:InitializeDevelPackage attribute, a similar issue to CVE-2018-7689.
- Record
DEBIAN-CVE-2018-12467- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-12467
6.0
Authorized users of the openbuildservice before 2.9.4 could delete packages by using a malicious request against projects having the OBS:InitializeDevelPackage attribute, a similar issue to CVE-2018-7689.
- Record
UBUNTU-CVE-2018-12467- CVSS 3.0
- 6.0 Medium
CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:H - CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
open-build-serviceDebian:12 |
before 2.9.4-1 | 2.9.4-1 |
open-build-serviceUbuntu:18.04:LTS |
All versions, plus listed versions 2.7.4-2 |
None known |
open-build-serviceUbuntu:24.04:LTS |
All versions, plus listed versions 2.9.4-92.9.4-10 |
None known |
open-build-serviceUbuntu:25.10 |
All versions, plus listed versions 2.9.4-10 |
None known |
open-build-serviceUbuntu:26.04:LTS |
All versions, plus listed versions 2.9.4-10 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-12467 is a medium vulnerability (CVSS 6.0) in Opensuse Openbuildservice, published August 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.65%, the 51st percentile. Fixed in open-build-service 2.9.4-1.
References
github.com/openSUSE/open-build-service/commit/f57b660f49f830006766a8d4abc3b4af6e178063
bugzilla.suse.com/show_bug.cgi?id=1100217
nvd.nist.gov/vuln/detail/CVE-2018-12467
github.com/advisories/GHSA-24pm-f3f4-m533
security-tracker.debian.org/tracker/CVE-2018-12467
ubuntu.com/security/CVE-2018-12467
cve.org/CVERecord?id=CVE-2018-12467