Every CVE Search/ Get API key

CVE-2018-12482

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is...

8.8 HighFix available

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is needed in order to exploit the issues.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.30%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is needed in order to exploit the issues.

Record
CVE-2018-12482
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is needed in order to exploit the issues.

Record
CVE-2018-12482
Updated
2026-11-02
EUVDEUVD-2018-4452 No score

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is needed in order to exploit the issues.

Record
EUVD-2018-4452
Updated
2026-11-03
GitHub AdvisoriesGHSA-h46q-44pm-ghrg 8.8

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is...

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is needed in order to exploit the issues.

Record
GHSA-h46q-44pm-ghrg
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSV 8.8

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is needed in order to exploit the issues.

Record
CVE-2018-12482
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-12482 8.8

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is needed in order to exploit the issues.

Record
DEBIAN-CVE-2018-12482
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-12482 8.8

OCS Inventory 2.4.1 contains multiple SQL injections in the search engine. Authentication is needed in order to exploit the issues.

Record
UBUNTU-CVE-2018-12482
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ocsinventory-server
Debian:12
before 2.5+dfsg-1
2.5+dfsg-1
ocsinventory-server
Ubuntu:16.04:LTS
All versions, plus listed versions
2.1.2-12.1.2-1ubuntu1
None known
ocsinventory-server
Ubuntu:18.04:LTS
All versions, plus listed versions
2.2+dfsg-0.1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-12482 is a high vulnerability (CVSS 8.8) in Ocsinventory-ng Ocsinventory Ng, published August 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.30%, the 70th percentile. Fixed in ocsinventory-server 2.5+dfsg-1.

References

MoveEnter Open