Every CVE Search/ Get API key

CVE-2018-16790

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and...

8.1 HighFix available

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and other products, has a heap-based buffer over-read via a crafted bson buffer.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

2.13%Up 1.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and other products, has a heap-based buffer over-read via a crafted bson buffer.

Record
CVE-2018-16790
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and other products, has a heap-based buffer over-read via a crafted bson buffer.

Record
CVE-2018-16790
Updated
2026-11-02
EUVDEUVD-2018-8590 No score

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and other products, has a heap-based buffer over-read via a crafted bson buffer.

Record
EUVD-2018-8590
Updated
2026-11-02
GitHub AdvisoriesGHSA-vmg6-94hc-5vqp 8.1

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and...

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and other products, has a heap-based buffer over-read via a crafted bson buffer.

Record
GHSA-vmg6-94hc-5vqp
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 8.1

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and other products, has a heap-based buffer over-read via a crafted bson buffer.

Record
CVE-2018-16790
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-16790 8.1

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and other products, has a heap-based buffer over-read via a crafted bson buffer.

Record
DEBIAN-CVE-2018-16790
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-16790 8.1

_bson_iter_next_internal in bson-iter.c in libbson 1.12.0, as used in MongoDB mongo-c-driver and other products, has a heap-based buffer over-read via a crafted bson buffer.

Record
UBUNTU-CVE-2018-16790
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVUSN-4812-1 No score

libbson vulnerabilities

It was discovered that libbson incorrectly validated input length. An attacker could possibly use this issue to cause a denial of service. This issue affected only Ubuntu 16.04 ESM. (CVE-2017-14227)

It was discovered that libbson incorrectly handled certain specially crafted bson buffers. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-16790)

Record
USN-4812-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libbson-xs-perl
Debian:12
before 0.8.4-2+deb12u1, plus listed versions
0.8.4-2
0.8.4-2+deb12u1
mongo-c-driver
Debian:12
before 1.13.0-1
1.13.0-1
mongo-c-driver
Debian:13
before 1.13.0-1
1.13.0-1
mongo-c-driver
Debian:14
before 1.13.0-1
1.13.0-1
libbson-xs-perl
Debian:11
before 0.8.4-1+deb11u1, plus listed versions
0.8.4-1
0.8.4-1+deb11u1
libbson
Ubuntu:Pro:16.04:LTS
before 1.3.1-1ubuntu0.1~esm1, plus listed versions
1.3.1-1
1.3.1-1ubuntu0.1~esm1
libbson
Ubuntu:Pro:18.04:LTS
before 1.9.2-1ubuntu0.1~esm2, plus listed versions
1.8.0-11.8.1-11.9.0-11.9.2-1
1.9.2-1ubuntu0.1~esm2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-16790 is a high vulnerability (CVSS 8.1) in Mongodb Libbson, published September 10, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.13%, the 81st percentile. Fixed in libbson-xs-perl 0.8.4-2+deb12u1.

References

Show 6 moreShow less
MoveEnter Open