Every CVE Search/ Get API key

CVE-2018-17953

pam_access does not handle netmask matches correctly

7.5 HighFix available

A incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in openSUSE Leap 15.0 and SUSE Linux Enterprise 15 could lead to pam_access rules not being applied (fail open).

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.34%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.5

pam_access does not handle netmask matches correctly

A incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in openSUSE Leap 15.0 and SUSE Linux Enterprise 15 could lead to pam_access rules not being applied (fail open).

Record
CVE-2018-17953
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-284
Updated
2026-11-02
EUVDEUVD-2018-9694 7.5

A incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in openSUSE Leap 15.0 and SUSE Linux Enterprise 15 could lead to pam_access rules not being applied (fail open).

Record
EUVD-2018-9694
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-wwc4-7rwv-m5ch 8.1

A incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in...

A incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in openSUSE Leap 15.0 and SUSE Linux Enterprise 15 could lead to pam_access rules not being applied (fail open).

Record
GHSA-wwc4-7rwv-m5ch
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
NVD 7.5

A incorrect variable in a SUSE specific patch for pam_access rule matching in PAM 1.3.0 in openSUSE Leap 15.0 and SUSE Linux Enterprise 15 could lead to pam_access rules not being applied (fail open).

Record
CVE-2018-17953
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-284
Updated
2026-11-02
OSVopenSUSE-SU-2024:11140-1 No score

pam-1.5.2-1.1 on GA media

These are all security issues fixed in the pam-1.5.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11140-1
Updated
2026-11-02
OSVSUSE-SU-2018:3965-1 No score

Security update for pam

This update for pam fixes the following issue:

Security issue fixed:

  • CVE-2018-17953: Fixed IP address and subnet handling of pam_access.so that was not honoured correctly when a single host was specified (bsc#1115640).
Record
SUSE-SU-2018:3965-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pam
SUSE:Linux Enterprise Module for Basesystem 15
before 1.3.0-6.6.1
1.3.0-6.6.1
pam
SUSE:Linux Enterprise Module for Development Tools 15
before 1.3.0-6.6.1
1.3.0-6.6.1
pam
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 1.5.2-1.1
1.5.2-1.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-17953 is a high vulnerability (CVSS 7.5) in Suse Pam, published November 27, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.34%, the 71st percentile. Fixed in pam 1.3.0-6.6.1.

References

MoveEnter Open