Every CVE Search/ Get API key

CVE-2018-20244

Apache Airflow vulnerable to Stored XSS

5.5 MediumFix available

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.96%Down 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Record
CVE-2018-20244
CVSS 3.0
5.5 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Record
CVE-2018-20244
Updated
2026-11-02
EUVDEUVD-2019-0010 No score

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Record
EUVD-2019-0010
Updated
2026-11-03
GitHub AdvisoriesGHSA-99cv-8cvv-666c 5.1

Apache Airflow vulnerable to Stored XSS

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Record
GHSA-99cv-8cvv-666c
CVSS 4.0
5.1 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
5.5 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.5

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Record
CVE-2018-20244
CVSS 3.0
5.5 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-99cv-8cvv-666c 5.1

Apache Airflow vulnerable to Stored XSS

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Record
GHSA-99cv-8cvv-666c
CVSS 4.0
5.1 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.0
5.5 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2019-142 No score

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

Record
PYSEC-2019-142
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apache-airflow
PyPI
before 1.10.2
1.10.2
apache-airflow
PyPI
before 1.10.2, plus listed versions
1.10.01.10.11.10.1b11.10.1rc21.10.2b2
Show 7 moreShow less
1.10.2rc11.10.2rc21.10.2rc31.8.11.8.21.8.2rc11.9.0
1.10.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-20244 is a medium vulnerability (CVSS 5.5) in Apache Airflow, published February 27, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.96%, the 80th percentile. Fixed in apache-airflow 1.10.2.

References

Show 5 moreShow less
MoveEnter Open