CVE-2016-10523
Denial of Service in mqtt-packet
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
- Record
CVE-2016-10523- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-400, CWE-119
- Updated
- 2026-11-02
CVE List No score
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
- Record
CVE-2016-10523- Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2019-0286 No score
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
- Record
EUVD-2019-0286- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g3r2-65gc-qpqc No score
Denial of Service in mqtt-packet
Versions of mqtt-packet prior to 3.4.6, or 4.x prior to 4.0.5 are affected by a denial of service vulnerability wherein specific sequences of MQTT packets can crash the application.
Recommendation
Version 3.x: Update to version 3.4.6 or later. Version 4.x: Update to version 4.0.5 or later.
- Record
GHSA-g3r2-65gc-qpqc- Weakness
- CWE-400
- Updated
- 2026-11-02
OSV
7.5
MQTT before 3.4.6 and 4.0.x before 4.0.5 allows specifically crafted MQTT packets to crash the application, making a DoS attack feasible with very little bandwidth.
- Record
CVE-2016-10523- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-g3r2-65gc-qpqc No score
Denial of Service in mqtt-packet
Versions of mqtt-packet prior to 3.4.6, or 4.x prior to 4.0.5 are affected by a denial of service vulnerability wherein specific sequences of MQTT packets can crash the application.
Recommendation
Version 3.x: Update to version 3.4.6 or later. Version 4.x: Update to version 4.0.5 or later.
- Record
GHSA-g3r2-65gc-qpqc- Weakness
- CWE-400
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mqtt-packetnpm |
before 3.4.6 | 3.4.6 |
mqtt-packetnpm |
4.0.0 up to 4.0.5 | 4.0.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10523 is a high vulnerability (CVSS 7.5) in Mqtt-packet Project Mqtt-packet, published May 31, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.42%, the 84th percentile. Fixed in mqtt-packet 3.4.6.