Every CVE Search/ Get API key

CVE-2018-16484

Cross-Site Scripting in m-server

5.4 MediumFix available

A XSS vulnerability was found in module m-server <1.4.2 that allows malicious Javascript code or HTML to be executed, due to the lack of escaping for special characters in folder names.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.61%Down 1.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.4

A XSS vulnerability was found in module m-server <1.4.2 that allows malicious Javascript code or HTML to be executed, due to the lack of escaping for special characters in folder names.

Record
CVE-2018-16484
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A XSS vulnerability was found in module m-server <1.4.2 that allows malicious Javascript code or HTML to be executed, due to the lack of escaping for special characters in folder names.

Record
CVE-2018-16484
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2019-0295 No score

A XSS vulnerability was found in module m-server <1.4.2 that allows malicious Javascript code or HTML to be executed, due to the lack of escaping for special characters in folder names.

Record
EUVD-2019-0295
Updated
2026-11-03
GitHub AdvisoriesGHSA-gmxv-xf2q-6j8m 5.4

Cross-Site Scripting in m-server

Versions of m-server before 1.4.2 are vulnerable to stored cross-site scripting. This vulnerability is exploitable if an attacker is able to control the name of a file that m-server is serving.

Recommendation

Update to version 1.4.2 or later.

Record
GHSA-gmxv-xf2q-6j8m
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-gmxv-xf2q-6j8m 5.4

Cross-Site Scripting in m-server

Versions of m-server before 1.4.2 are vulnerable to stored cross-site scripting. This vulnerability is exploitable if an attacker is able to control the name of a file that m-server is serving.

Recommendation

Update to version 1.4.2 or later.

Record
GHSA-gmxv-xf2q-6j8m
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
m-server
npm
before 1.4.2
1.4.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-16484 is a medium vulnerability (CVSS 5.4) in Hackerone M-server, published February 1, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in m-server 1.4.2.

References

MoveEnter Open