CVE-2016-10527
Regular Expression Denial of Service in riot-compiler
The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.
- Record
CVE-2016-10527- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-400, CWE-399
- Updated
- 2026-11-02
CVE List No score
The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.
- Record
CVE-2016-10527- Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2019-0324 No score
The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.
- Record
EUVD-2019-0324- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pp4v-55vr-9gxh
7.5
Regular Expression Denial of Service in riot-compiler
Affected versions of riot-compiler are susceptible to a regular expression denial of service vulnerability.
Recommendation
Update to version 2.3.22 or later.
- Record
GHSA-pp4v-55vr-9gxh- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
OSV
7.5
The riot-compiler version version 2.3.21 has an issue in a regex (Catastrophic Backtracking) thats make it unusable under certain conditions.
- Record
CVE-2016-10527- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-pp4v-55vr-9gxh
7.5
Regular Expression Denial of Service in riot-compiler
Affected versions of riot-compiler are susceptible to a regular expression denial of service vulnerability.
Recommendation
Update to version 2.3.22 or later.
- Record
GHSA-pp4v-55vr-9gxh- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-400
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
riot-compilernpm |
before 2.3.22 | 2.3.22 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2016-10527 is a high vulnerability (CVSS 7.5) in Riot.js Riot-compiler, published May 31, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.57%, the 75th percentile. Fixed in riot-compiler 2.3.22.