CVE-2018-16492
Prototype Pollution in extend
A prototype pollution vulnerability was found in module extend <2.0.2, ~<3.0.2 that allows an attacker to inject arbitrary properties onto Object.prototype.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A prototype pollution vulnerability was found in module extend <2.0.2, ~<3.0.2 that allows an attacker to inject arbitrary properties onto Object.prototype.
- Record
CVE-2018-16492- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-400, CWE-74
- Updated
- 2026-11-02
CVE List No score
A prototype pollution vulnerability was found in module extend <2.0.2, ~<3.0.2 that allows an attacker to inject arbitrary properties onto Object.prototype.
- Record
CVE-2018-16492- Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2019-0333 No score
A prototype pollution vulnerability was found in module extend <2.0.2, ~<3.0.2 that allows an attacker to inject arbitrary properties onto Object.prototype.
- Record
EUVD-2019-0333- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qrmc-fj45-qfc2 No score
Prototype Pollution in extend
Versions of extend prior to 3.0.2 (for 3.x) and 2.0.2 (for 2.x) are vulnerable to Prototype Pollution. The extend() function allows attackers to modify the prototype of Object causing the addition or modification of an existing property that will exist on all objects.
Recommendation
If you're using extend 3.x upgrade to 3.0.2 or later.
If you're using extend 2.x upgrade to 2.0.2 or later.
- Record
GHSA-qrmc-fj45-qfc2- Weakness
- CWE-400
- Updated
- 2026-11-02
OSV
9.8
A prototype pollution vulnerability was found in module extend <2.0.2, ~<3.0.2 that allows an attacker to inject arbitrary properties onto Object.prototype.
- Record
CVE-2018-16492- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-16492
9.8
A prototype pollution vulnerability was found in module extend <2.0.2, ~<3.0.2 that allows an attacker to inject arbitrary properties onto Object.prototype.
- Record
DEBIAN-CVE-2018-16492- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-16492
9.8
A prototype pollution vulnerability was found in module extend <2.0.2, ~<3.0.2 that allows an attacker to inject arbitrary properties onto Object.prototype.
- Record
UBUNTU-CVE-2018-16492- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVCLSA-2026-1773188141 No score
TuxCare security update for extend (1 CVE)
TuxCare rebuilt extend to address 1 CVE. Fixed in 3.0.0-tuxcare.3.
- Record
CLSA-2026-1773188141- Updated
- 2026-11-02
OSVGHSA-qrmc-fj45-qfc2 No score
Prototype Pollution in extend
Versions of extend prior to 3.0.2 (for 3.x) and 2.0.2 (for 2.x) are vulnerable to Prototype Pollution. The extend() function allows attackers to modify the prototype of Object causing the addition or modification of an existing property that will exist on all objects.
Recommendation
If you're using extend 3.x upgrade to 3.0.2 or later.
If you're using extend 2.x upgrade to 2.0.2 or later.
- Record
GHSA-qrmc-fj45-qfc2- Weakness
- CWE-400
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
extendnpm |
3.0.0 up to 3.0.2 | 3.0.2 |
extendnpm |
1.1.3 up to 2.0.2 | 2.0.2 |
extendTuxCare:npm |
3.0.0-tuxcare.0 up to 3.0.0-tuxcare.3, plus listed versions 3.0.03.0.0-tuxcare.13.0.0-tuxcare.2 |
3.0.0-tuxcare.3 |
node-extendDebian:12 |
before 3.0.2-1 | 3.0.2-1 |
node-extendDebian:13 |
before 3.0.2-1 | 3.0.2-1 |
node-extendDebian:14 |
before 3.0.2-1 | 3.0.2-1 |
node-extendUbuntu:16.04:LTS |
All versions, plus listed versions 2.0.0-1 |
None known |
node-extendUbuntu:18.04:LTS |
All versions, plus listed versions 2.0.0-1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | dsp-testing/CVE-2018-16492 | 2021-01-05 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-16492 is a critical vulnerability (CVSS 9.8) in Extend Project Extend, published February 1, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.05%, the 87th percentile. Fixed in extend 3.0.2.