Every CVE Search/ Get API key

CVE-2017-12625

Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service

4.3 MediumFix available

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
None

Exploit likelihood

1.43%Down 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.3

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Record
CVE-2017-12625
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:P/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Record
CVE-2017-12625
Updated
2026-11-02
EUVDEUVD-2019-0367 No score

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Record
EUVD-2019-0367
Updated
2026-11-03
GitHub AdvisoriesGHSA-2g9q-chq2-w8qw 4.3

Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Record
GHSA-2g9q-chq2-w8qw
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 4.3

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Record
CVE-2017-12625
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Updated
2026-11-02
OSVGHSA-2g9q-chq2-w8qw 4.3

Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Record
GHSA-2g9q-chq2-w8qw
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.hive:hive
Maven
2.1.0 up to 2.1.2
2.1.2
org.apache.hive:hive
Maven
2.2.0 to 2.2.0
2.2.1
org.apache.hive:hive
Maven
2.3.0 to 2.3.0
2.3.1
org.apache.hive:hive-exec
Maven
2.1.0 up to 2.1.2
2.1.2
org.apache.hive:hive-exec
Maven
2.2.0 to 2.2.0
2.2.1
org.apache.hive:hive-exec
Maven
2.3.0 to 2.3.0
2.3.1
org.apache.hive:hive-service
Maven
2.1.0 up to 2.1.2
2.1.2
org.apache.hive:hive-service
Maven
2.2.0 to 2.2.0
2.2.1
org.apache.hive:hive-service
Maven
2.3.0 to 2.3.0
2.3.1
org.apache.hive:hive
Maven
2.1.0 up to 2.1.2, plus listed versions
2.1.1
2.1.2
Show 8 moreShow less
Affected packages
PackageAffectedFixed
org.apache.hive:hive
Maven
2.2.0 up to 2.2.1
2.2.1
org.apache.hive:hive
Maven
2.3.0 up to 2.3.1
2.3.1
org.apache.hive:hive-exec
Maven
2.1.0 up to 2.1.2, plus listed versions
2.1.1
2.1.2
org.apache.hive:hive-exec
Maven
2.2.0 up to 2.2.1
2.2.1
org.apache.hive:hive-exec
Maven
2.3.0 up to 2.3.1
2.3.1
org.apache.hive:hive-service
Maven
2.1.0 up to 2.1.2, plus listed versions
2.1.1
2.1.2
org.apache.hive:hive-service
Maven
2.2.0 up to 2.2.1
2.2.1
org.apache.hive:hive-service
Maven
2.3.0 up to 2.3.1
2.3.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-12625 is a medium vulnerability (CVSS 4.3) in Apache Hive, published November 1, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.43%, the 73rd percentile. Fixed in org.apache.hive:hive 2.1.2.

References

MoveEnter Open