CVE-2018-11767
Improper Privilege Management in org.apache.hadoop:hadoop-main
In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system uses non-default groups mapping mechanisms.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.4
In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system uses non-default groups mapping mechanisms.
- Record
CVE-2018-11767- CVSS 3.0
- 7.4 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:P - Weakness
- CWE-269
- Updated
- 2026-11-02
CVE List No score
In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system uses non-default groups mapping mechanisms.
- Record
CVE-2018-11767- Updated
- 2026-11-02
EUVDEUVD-2019-0370 No score
In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system uses non-default groups mapping mechanisms.
- Record
EUVD-2019-0370- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5cf4-jqwp-584g
7.4
Improper Privilege Management in org.apache.hadoop:hadoop-main
In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system uses non-default groups mapping mechanisms.
- Record
GHSA-5cf4-jqwp-584g- CVSS 3.0
- 7.4 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSV
7.4
In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system uses non-default groups mapping mechanisms.
- Record
CVE-2018-11767- CVSS 3.0
- 7.4 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-5cf4-jqwp-584g
7.4
Improper Privilege Management in org.apache.hadoop:hadoop-main
In Apache Hadoop 2.9.0 to 2.9.1, 2.8.3 to 2.8.4, 2.7.5 to 2.7.6, KMS blocking users or granting access to users incorrectly, if the system uses non-default groups mapping mechanisms.
- Record
GHSA-5cf4-jqwp-584g- CVSS 3.0
- 7.4 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.hadoop:hadoop-mainMaven |
2.7.5 up to 2.7.7 | 2.7.7 |
org.apache.hadoop:hadoop-mainMaven |
2.8.3 up to 2.8.5 | 2.8.5 |
org.apache.hadoop:hadoop-mainMaven |
2.9.0 up to 2.9.2 | 2.9.2 |
org.apache.hadoop:hadoop-mainMaven |
2.7.5 up to 2.7.7, plus listed versions 2.7.6 |
2.7.7 |
org.apache.hadoop:hadoop-mainMaven |
2.8.3 up to 2.8.5, plus listed versions 2.8.4 |
2.8.5 |
org.apache.hadoop:hadoop-mainMaven |
2.9.0 up to 2.9.2, plus listed versions 2.9.1 |
2.9.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-11767 is a high vulnerability (CVSS 7.4) in Apache Hadoop, published March 18, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.73%, the 89th percentile. Fixed in org.apache.hadoop:hadoop-main 2.7.7.
References
lists.apache.org/thread.html/5fb771f66946dd5c99a8a5713347c24873846f555d716f9ac17bccca%40%3Cgeneral.hadoop.apache.org%3E
lists.apache.org/thread.html/246cf223e7dc0c1dff90b78dccb6c3fe94e1a044dbf98e2333393302%40%3Ccommon-issues.hadoop.apache.org%3E
lists.apache.org/thread.html/5a44590b4eedc5e25f5bd3081d1631b52c174b5b99157f7950ddc270%40%3Ccommon-dev.hadoop.apache.org%3E
security.netapp.com/advisory/ntap-20190416-0009
lists.apache.org/thread.html/9317fd092b257a0815434b116a8af8daea6e920b6673f4fd5583d5fe%40%3Ccommits.druid.apache.org%3E
nvd.nist.gov/vuln/detail/CVE-2018-11767
Show 5 moreShow less
github.com/advisories/GHSA-5cf4-jqwp-584g
lists.apache.org/thread.html/246cf223e7dc0c1dff90b78dccb6c3fe94e1a044dbf98e2333393302@%3Ccommon-issues.hadoop.apache.org%3E
lists.apache.org/thread.html/5a44590b4eedc5e25f5bd3081d1631b52c174b5b99157f7950ddc270@%3Ccommon-dev.hadoop.apache.org%3E
lists.apache.org/thread.html/5fb771f66946dd5c99a8a5713347c24873846f555d716f9ac17bccca@%3Cgeneral.hadoop.apache.org%3E
lists.apache.org/thread.html/9317fd092b257a0815434b116a8af8daea6e920b6673f4fd5583d5fe@%3Ccommits.druid.apache.org%3E