Every CVE Search/ Get API key

CVE-2019-0227

Server Side Request Forgery in Apache Axis

7.5 HighPublic exploitFix available

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

91.9%Up 73.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Record
CVE-2019-0227
CVSS 3.1
7.5 HighCVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
5.4 MediumAV:A/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-918
Updated
2026-11-02
CVE List No score

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Record
CVE-2019-0227
Updated
2026-11-02
EUVDEUVD-2019-0467 No score

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Record
EUVD-2019-0467
Updated
2026-11-03
GitHub AdvisoriesGHSA-h9gj-rqrw-x4fq 7.5

Server Side Request Forgery in Apache Axis

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Record
GHSA-h9gj-rqrw-x4fq
CVSS 3.1
7.5 HighCVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02
OSV 7.5

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Record
CVE-2019-0227
CVSS 3.1
7.5 HighCVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-0227 7.5

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Record
DEBIAN-CVE-2019-0227
CVSS 3.1
7.5 HighCVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-h9gj-rqrw-x4fq 7.5

Server Side Request Forgery in Apache Axis

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Record
GHSA-h9gj-rqrw-x4fq
CVSS 3.1
7.5 HighCVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-918
Updated
2026-11-02
OSVUBUNTU-CVE-2019-0227 7.5

A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue.

Record
UBUNTU-CVE-2019-0227
CVSS 3.1
7.5 HighCVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVCLSA-2026-1771459786 No score

TuxCare security update for org.apache.axis:axis (3 CVEs)

TuxCare rebuilt org.apache.axis:axis to address 3 CVEs. Fixed in 1.4-tuxcare.1.

Record
CLSA-2026-1771459786
Updated
2026-11-02

Affected products

Show 26 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
org.apache.axis:axis
Maven
through 1.4 None known
axis:axis
Maven
through 1.4 None known
org.apache.axis:axis
TuxCare:Maven
From an advisory covering 3 CVEs
1.4 up to 1.4-tuxcare.1
1.4-tuxcare.1
axis
Debian:12
All versions, plus listed versions
1.4-281.4-28+deb12u11.4-291.4-30
None known
axis
Debian:13
All versions, plus listed versions
1.4-291.4-30
None known
axis
Debian:14
before 1.4-30, plus listed versions
1.4-29
1.4-30
axis:axis
Maven
through 1.4, plus listed versions
1.01.11.1-beta1.21.2-RC1
Show 7 moreShow less
1.2-RC21.2-RC31.2-alpha-11.2-beta-21.2-beta-31.2.11.3
None known
axis
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.4-221.4-231.4-241.4-24ubuntu0.1~esm1
None known
axis
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
1.4-251.4-25ubuntu0.1~esm1
None known
axis
Ubuntu:20.04:LTS
All versions, plus listed versions
1.4-281.4-28+deb10u1build0.20.04.1
None known
Show 5 moreShow less
Affected packages
PackageAffectedFixed
axis
Ubuntu:22.04:LTS
All versions, plus listed versions
1.4-281.4-28+deb10u1build0.22.04.1
None known
axis
Ubuntu:24.04:LTS
All versions, plus listed versions
1.4-281.4-29
None known
axis
Ubuntu:25.10
All versions, plus listed versions
1.4-29
None known
axis
Ubuntu:26.10
All versions, plus listed versions
1.4-29build1
None known
axis
Ubuntu:26.04:LTS
All versions, plus listed versions
1.4-291.4-29build1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBApache Axis 1.4 - Remote Code Execution2019-04-09
PoC in GitHubianxtianxt/cve-2019-02272019-10-27
PoC in GitHub1475210817/Axis1.4-CVE-2019-02272026-05-16

History

History
RecordedChangedSources
affected, exploits, facts
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-0227 is a high vulnerability (CVSS 7.5) in Apache Axis 1.4, published May 1, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 91.9%, the 99th percentile. Fixed in axis 1.4-30.

References

Show 14 moreShow less
MoveEnter Open