CVE-2015-9284
OmniAuth Ruby gem Cross-site Request Forgery in request phase
CVE-2015-9284 is a high vulnerability (CVSS 8.8) in Omniauth, published April 26, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.52%, the 74th percentile. Fixed in omniauth 2.0.0.
The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
- Record
CVE-2015-9284- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
- Record
CVE-2015-9284- Weakness
- CWE-352
- Updated
- 2026-11-02
EUVDEUVD-2019-0482 No score
The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
- Record
EUVD-2019-0482- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ww4x-rwq6-qpgf
8.8
OmniAuth Ruby gem Cross-site Request Forgery in request phase
The request phase of the OmniAuth Ruby gem (1.9.2 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
As of v2 OmniAuth no longer has the vulnerable configuration by default, but it is still possible to configure OmniAuth in such a way that the web application becomes vulnerable to Cross-Site Request Forgery. There is a recommended remediation described here.
- Record
GHSA-ww4x-rwq6-qpgf- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
8.8
The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
- Record
CVE-2015-9284- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2015-9284
8.8
The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
- Record
DEBIAN-CVE-2015-9284- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-ww4x-rwq6-qpgf
8.8
OmniAuth Ruby gem Cross-site Request Forgery in request phase
The request phase of the OmniAuth Ruby gem (1.9.2 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
As of v2 OmniAuth no longer has the vulnerable configuration by default, but it is still possible to configure OmniAuth in such a way that the web application becomes vulnerable to Cross-Site Request Forgery. There is a recommended remediation described here.
- Record
GHSA-ww4x-rwq6-qpgf- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-352
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2015-9284
8.8
The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby on Rails framework, allowing accounts to be connected without user intent, user interaction, or feedback to the user. This permits a secondary account to be able to sign into the web application as the primary account.
- Record
UBUNTU-CVE-2015-9284- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
omniauthRubyGems |
through 1.9.2 | 2.0.0 |
ruby-omniauthDebian:12 |
before 2.0.4-2 | 2.0.4-2 |
ruby-omniauthDebian:13 |
before 2.0.4-2 | 2.0.4-2 |
ruby-omniauthDebian:14 |
before 2.0.4-2 | 2.0.4-2 |
omniauthRubyGems |
before 2.0.0, plus listed versions 0.0.10.0.30.0.40.0.50.1.0 Show 45 moreShow less0.1.10.1.20.1.30.1.40.1.50.1.60.2.00.2.0.beta10.2.0.beta20.2.0.beta30.2.0.beta40.2.0.beta50.2.10.2.20.2.30.2.40.2.50.2.60.3.00.3.0.rc30.3.21.0.01.0.0.beta11.0.0.pr11.0.0.pr21.0.0.rc11.0.0.rc21.0.11.0.21.0.31.1.01.1.11.1.21.1.31.1.41.2.11.2.21.3.01.3.11.3.21.4.01.4.11.4.21.4.31.5.0 |
2.0.0 |
ruby-omniauthUbuntu:16.04:LTS |
All versions, plus listed versions 1.2.2-31.3.1-11.3.1-1+deb9u1build0.16.04.1 |
None known |
ruby-omniauthUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.1-11.3.1-21.6.1-2 |
None known |
ruby-omniauthUbuntu:20.04:LTS |
All versions, plus listed versions 1.8.1-11.9.0-1 |
None known |
ruby-omniauthUbuntu:22.04:LTS |
All versions, plus listed versions 1.9.1-1 |
None known |
ruby-omniauthUbuntu:24.04:LTS |
All versions, plus listed versions 2.1.1-1 |
None known |
ruby-omniauthUbuntu:25.10 |
All versions, plus listed versions 2.1.1-4 |
None known |
ruby-omniauthUbuntu:26.10 |
All versions, plus listed versions 2.1.4-1 |
None known |
ruby-omniauthUbuntu:26.04:LTS |
All versions, plus listed versions 2.1.1-42.1.4-1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/omniauth/omniauth/pull/809
github.com/omniauth/omniauth-rails/pull/1
openwall.com/lists/oss-security/2015/05/26/11
github.com/omniauth/omniauth/wiki/Resolving-CVE-2015-9284
nvd.nist.gov/vuln/detail/CVE-2015-9284
github.com/rubysec/ruby-advisory-db/commit/aef9f623c0be838234d53baf18977564804da397
Show 9 moreShow less
github.com/omniauth/omniauth/releases/tag/v2.0.0
github.com/omniauth/omniauth/issues/1031
github.com/omniauth/omniauth/releases/tag/v1.9.2
github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth/CVE-2015-9284.yml
github.com/advisories/GHSA-ww4x-rwq6-qpgf
security-tracker.debian.org/tracker/CVE-2015-9284
github.com/omniauth/omniauth
ubuntu.com/security/CVE-2015-9284
cve.org/CVERecord?id=CVE-2015-9284
Left out here: 10 versions. The JSON record has them.