CVE-2019-13506
Cross-Site Scripting in @nuxt/devalue
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS.
- Record
CVE-2019-13506- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS.
- Record
CVE-2019-13506- Updated
- 2026-11-02
EUVDEUVD-2019-0580 No score
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS.
- Record
EUVD-2019-0580- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6677-83pp-f862
6.1
Cross-Site Scripting in @nuxt/devalue
Versions of @nuxt/devalue prior to 1.2.3 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization attacker may inject arbitrary JavaScript code through object keys.
Recommendation
Upgrade to version 1.2.3 or later.
- Record
GHSA-6677-83pp-f862- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS.
- Record
CVE-2019-13506- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-05
OSVGHSA-6677-83pp-f862
6.1
Cross-Site Scripting in @nuxt/devalue
Versions of @nuxt/devalue prior to 1.2.3 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization attacker may inject arbitrary JavaScript code through object keys.
Recommendation
Upgrade to version 1.2.3 or later.
- Record
GHSA-6677-83pp-f862- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@nuxt/devaluenpm |
before 1.2.3 | 1.2.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-13506 is a medium vulnerability (CVSS 6.1) in Nuxtjs Nuxt.js, published July 11, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.35%, the 71st percentile. Fixed in @nuxt/devalue 1.2.3.
References
github.com/nuxt/nuxt.js/releases/tag/v2.6.2
github.com/nuxt/devalue/pull/8
github.com/nuxt/nuxt.js/commit/0d5dfe71917191c5b07f373896311f2d8f6b75be
github.com/nuxt/devalue/releases/tag/v1.2.3
github.com/nuxt/nuxt.js/compare/c0776eb...8d14cd4
npmjs.com/advisories/814
nvd.nist.gov/vuln/detail/CVE-2019-13506
github.com/Rich-Harris/devalue/issues/19
github.com/advisories/GHSA-6677-83pp-f862