Every CVE Search/ Get API key

CVE-2019-0228

Vulnerability that affects org.apache.pdfbox:pdfbox

9.8 CriticalFix available

Apache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

9.45%Up 3.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Apache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.

Record
CVE-2019-0228
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-611
Updated
2026-11-02
CVE List No score

Apache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.

Record
CVE-2019-0228
Updated
2026-11-02
EUVDEUVD-2019-0587 No score

Apache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.

Record
EUVD-2019-0587
Updated
2026-11-03
GitHub AdvisoriesGHSA-c9jj-3wvg-q65h 9.8

Vulnerability that affects org.apache.pdfbox:pdfbox

Apache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.

Record
GHSA-c9jj-3wvg-q65h
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-611
Updated
2026-11-02
OSV 9.8

Apache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.

Record
CVE-2019-0228
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-c9jj-3wvg-q65h 9.8

Vulnerability that affects org.apache.pdfbox:pdfbox

Apache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.

Record
GHSA-c9jj-3wvg-q65h
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-611
Updated
2026-11-02

Affected products

Show 3 moreShow less

Affected packages

Affected packages
PackageAffectedFixed
org.apache.pdfbox:pdfbox
Maven
2.0.14 up to 2.0.15
2.0.15

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-0228 is a critical vulnerability (CVSS 9.8) in Apache Pdfbox, published April 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 9.45%, the 95th percentile. Fixed in org.apache.pdfbox:pdfbox 2.0.15.

References

Show 16 moreShow less
MoveEnter Open