Every CVE Search/ Get API key

CVE-2019-16761

Validator parsing discrepancy due to string encoding in NPM slp-validate 1.0.0

5.7 MediumFix available

A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the [email protected] npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. All versions >1.0.0 have been patched.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
High

Exploit likelihood

0.99%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 5.7

Validator parsing discrepancy due to string encoding in NPM slp-validate 1.0.0

A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the [email protected] npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. All versions >1.0.0 have been patched.

Record
CVE-2019-16761
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
EUVDEUVD-2019-0765 5.7

A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the [email protected] npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. All versions >1.0.0 have been patched.

Record
EUVD-2019-0765
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-wmx6-vxcf-c3gr 5.7

Validation Bypass in slp-validate

Versions of slp-validate prior to 1.0.1 are vulnerable to a validation bypass. Bitcoin scripts may cause the validation result from slp-validate to differ from the specified SLP consensus. This allows an attacker to create a Bitcoin script that causes a hard-fork from the SLP consensus.

Recommendation

Upgrade to version 1.0.1 or later.

Record
GHSA-wmx6-vxcf-c3gr
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
NVD 5.7

A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the [email protected] npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. All versions >1.0.0 have been patched.

Record
CVE-2019-16761
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:H
CVSS 2.0
4.9 MediumAV:N/AC:M/Au:S/C:N/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
OSV 6.1

A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the [email protected] npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. All versions >1.0.0 have been patched.

Record
CVE-2019-16761
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:H
Updated
2026-11-02
OSVGHSA-wmx6-vxcf-c3gr 5.7

Validation Bypass in slp-validate

Versions of slp-validate prior to 1.0.1 are vulnerable to a validation bypass. Bitcoin scripts may cause the validation result from slp-validate to differ from the specified SLP consensus. This allows an attacker to create a Bitcoin script that causes a hard-fork from the SLP consensus.

Recommendation

Upgrade to version 1.0.1 or later.

Record
GHSA-wmx6-vxcf-c3gr
CVSS 3.1
5.7 MediumCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
slp-validate
npm
1.0.0 to 1.0.0
1.0.1
slp-validate
npm
1.0.0 up to 1.0.1
1.0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-16761 is a medium vulnerability (CVSS 5.7) in Simpleledger Slp-validate, published November 15, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.99%, the 62nd percentile. Fixed in slp-validate 1.0.1.

References

MoveEnter Open