Every CVE Search/ Get API key

CVE-2019-10758

Remote Code Execution Vulnerability in NPM mongo-express

9.9 CriticalIn KEVPublic exploitFix available

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the toBSON method. A misuse of the vm dependency to perform exec commands in a non-safe environment.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

84.7%Up 80.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.9

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the toBSON method. A misuse of the vm dependency to perform exec commands in a non-safe environment.

Record
CVE-2019-10758
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Weakness
CWE-94
Updated
2026-11-02
CVE List 9.9

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the toBSON method. A misuse of the vm dependency to perform exec commands in a non-safe environment.

Record
CVE-2019-10758
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2019-0791 9.9

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the toBSON method. A misuse of the vm dependency to perform exec commands in a non-safe environment.

Record
EUVD-2019-0791
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-h47j-hc6x-h3qq 9.9

Remote Code Execution Vulnerability in NPM mongo-express

Impact

Remote code execution on the host machine by any authenticated user.

Proof Of Concept

Launching mongo-express on a Mac, pasting the following into the "create index" field will pop open the Mac calculator:

this.constructor.constructor("return process")().mainModule.require('child_process').execSync('/Applications/Calculator.app/Contents/MacOS/Calculator')

Patches

Users should upgrade to version 0.54.0

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

For more information

If you have any questions or comments about this advisory:

Thanks

@JLLeitschuh for finding and reporting this vulnerability

This vulnerability has been exploited in the wild.

Record
GHSA-h47j-hc6x-h3qq
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H
Weakness
CWE-78, CWE-94
Updated
2026-11-02
CISA KEV No score

MongoDB mongo-express Remote Code Execution Vulnerability

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the toBSON method.

Record
CVE-2019-10758
Updated
2026-11-02
OSV 9.9

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the toBSON method. A misuse of the vm dependency to perform exec commands in a non-safe environment.

Record
CVE-2019-10758
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-h47j-hc6x-h3qq 9.9

Remote Code Execution Vulnerability in NPM mongo-express

Impact

Remote code execution on the host machine by any authenticated user.

Proof Of Concept

Launching mongo-express on a Mac, pasting the following into the "create index" field will pop open the Mac calculator:

this.constructor.constructor("return process")().mainModule.require('child_process').execSync('/Applications/Calculator.app/Contents/MacOS/Calculator')

Patches

Users should upgrade to version 0.54.0

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

For more information

If you have any questions or comments about this advisory:

Thanks

@JLLeitschuh for finding and reporting this vulnerability

This vulnerability has been exploited in the wild.

Record
GHSA-h47j-hc6x-h3qq
CVSS 3.1
9.9 CriticalCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H
Weakness
CWE-78, CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mongo-express
npm
before 0.54.0
0.54.0

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubmasahiro331/CVE-2019-107582019-12-26
PoC in GitHublp008/CVE-2019-107582020-01-05
PoC in GitHubCyberCTF/vulhub-mongo-express-cve-2019-107582026-10-08
Nucleimongo-express Remote Code Execution

History

History
RecordedChangedSources
exploitation, exploits
first indexedCVE List, EUVD, GitHub Advisories, CISA KEV, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-10758 is a critical vulnerability (CVSS 9.9) in Mongo-express Project Mongo-express, published December 24, 2019. CISA lists it as known to be exploited, since December 10, 2021. EUVD reports exploitation since December 10, 2021. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 84.7%, the 99th percentile. Fixed in mongo-express 0.54.0.

References

Show 4 moreShow less
MoveEnter Open