Every CVE Search/ Get API key

CVE-2019-20051

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95....

5.5 MediumFix available

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.90%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service.

Record
CVE-2019-20051
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-682
Updated
2026-11-02
CVE List No score

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service.

Record
CVE-2019-20051
Updated
2026-11-02
EUVDEUVD-2019-10607 No score

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service.

Record
EUVD-2019-10607
Updated
2026-11-03
GitHub AdvisoriesGHSA-4pmq-77vh-vh7v 5.5

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95....

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service.

Record
GHSA-4pmq-77vh-vh7v
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-682
Updated
2026-11-02
OSV 5.5

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service.

Record
CVE-2019-20051
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-20051 5.5

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service.

Record
DEBIAN-CVE-2019-20051
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-20051 5.5

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service.

Record
UBUNTU-CVE-2019-20051
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2020-0096 No score

Updated upx packages fix security vulnerabilities

The updated packages fix security vulnerabilities:

PackLinuxElf64::unpack in p_lx_elf.cpp in UPX 3.95 allows remote attackers to cause a denial of service (double free), limit the ability of a malware scanner to operate on the entire original data, or possibly have unspecified other impact via a crafted file. (CVE-2018-11243)

A heap-based buffer over-read was discovered in canUnpack in p_mach.cpp in UPX 3.95 via a crafted Mach-O file. (CVE-2019-20021)

A floating-point exception was discovered in PackLinuxElf::elf_hash in p_lx_elf.cpp in UPX 3.95. The vulnerability causes an application crash, which leads to denial of service. (CVE-2019-20051)

An invalid memory address dereference was discovered in the canUnpack function in p_mach.cpp in UPX 3.95 via a crafted Mach-O file. (CVE-2019-20053)

A denial of service in PackLinuxElf32::PackLinuxElf32help1(). (CVE-2019-1010048)

Record
MGASA-2020-0096
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
upx-ucl
Debian:13
before 3.96-1
3.96-1
upx-ucl
Debian:14
before 3.96-1
3.96-1
upx
Mageia:7
From an advisory covering 5 CVEs
before 3.96-1.mga7
3.96-1.mga7
ucl
Mageia:7
From an advisory covering 5 CVEs
before 1.03-16.1.mga7
1.03-16.1.mga7
upx-ucl
Ubuntu:16.04:LTS
All versions, plus listed versions
3.91-1
None known
upx-ucl
Ubuntu:18.04:LTS
All versions, plus listed versions
3.94-23.94-33.94-4
None known
upx-ucl
Ubuntu:20.04:LTS
All versions, plus listed versions
3.95-23.95-2build1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-20051 is a medium vulnerability (CVSS 5.5) in Upx, published December 27, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.90%, the 59th percentile. Fixed in upx-ucl 3.96-1.

References

Show 9 moreShow less
MoveEnter Open