CVE-2019-8287
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function,...
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function, which can potentially result code execution. This attack appear to be exploitable via network connectivity.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function, which can potentially result code execution. This attack appear to be exploitable via network connectivity.
- Record
CVE-2019-8287- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List No score
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function, which can potentially result code execution. This attack appear to be exploitable via network connectivity.
- Record
CVE-2019-8287- Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2019-17685 No score
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function, which can potentially result code execution. This attack appear to be exploitable via network connectivity.
- Record
EUVD-2019-17685- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-frvw-vf5g-vxwg
9.8
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function,...
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function, which can potentially result code execution. This attack appear to be exploitable via network connectivity.
- Record
GHSA-frvw-vf5g-vxwg- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
9.8
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function, which can potentially result code execution. This attack appear to be exploitable via network connectivity.
- Record
CVE-2019-8287- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-8287
9.8
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function, which can potentially result code execution. This attack appear to be exploitable via network connectivity.
- Record
DEBIAN-CVE-2019-8287- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-8287
9.8
TightVNC code version 1.3.10 contains global buffer overflow in HandleCoRREBBP macro function, which can potentially result code execution. This attack appear to be exploitable via network connectivity.
- Record
UBUNTU-CVE-2019-8287- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVSUSE-SU-2019:14235-1 No score
Security update for tightvnc
This update for tightvnc fixes the following issues:
- CVE-2019-15679: Fixed a heap buffer overflow in InitialiseRFBConnection which might lead to code execution (bsc#1155476).
- CVE-2019-8287: Fixed a global buffer overflow in HandleCoRREBBPmay which might lead to code execution (bsc#1155472).
- CVE-2019-15680: Fixed a null pointer dereference in HandleZlibBPP which could have led to denial of service (bsc#1155452).
- CVE-2019-15678: Fixed a heap buffer overflow in rfbServerCutText handler (bsc#1155442).
- Record
SUSE-SU-2019:14235-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
tightvncDebian:12 |
before 1:1.3.9-9.1 | 1:1.3.9-9.1 |
tightvncDebian:13 |
before 1:1.3.9-9.1 | 1:1.3.9-9.1 |
tightvncDebian:14 |
before 1:1.3.9-9.1 | 1:1.3.9-9.1 |
tightvncDebian:8 From an advisory covering 9 CVEs |
before 1.3.9-6.5+deb8u1, plus listed versions 1.3.9-6.5 |
1.3.9-6.5+deb8u1 |
tightvncSUSE:Linux Enterprise Point of Sale 11 SP3 From an advisory covering 4 CVEs |
before 1.3.9-81.15.3.1 | 1.3.9-81.15.3.1 |
tightvncSUSE:Linux Enterprise Server 11 SP4-LTSS From an advisory covering 4 CVEs |
before 1.3.9-81.15.3.1 | 1.3.9-81.15.3.1 |
tightvncUbuntu:Pro:14.04:LTS |
before 1.3.9-6.5+deb8u1build0.14.04.1~esm1, plus listed versions 1.3.9-6.41.3.9-6.4ubuntu1 |
1.3.9-6.5+deb8u1build0.14.04.1~esm1 |
tightvncUbuntu:16.04:LTS |
All versions, plus listed versions 1.3.10-0ubuntu21.3.10-0ubuntu3 |
None known |
tightvncUbuntu:18.04:LTS |
All versions, plus listed versions 1.3.10-0ubuntu31.3.10-0ubuntu4 |
None known |
tightvncUbuntu:20.04:LTS |
All versions, plus listed versions 1.3.10-0ubuntu5 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
tightvncUbuntu:22.04:LTS |
All versions, plus listed versions 1:1.3.10-31:1.3.10-5 |
None known |
tightvncUbuntu:24.04:LTS |
All versions, plus listed versions 1:1.3.10-71:1.3.10-7build11:1.3.10-7build21:1.3.10-8 |
None known |
tightvncUbuntu:25.10 |
All versions, plus listed versions 1:1.3.10-91:1.3.10-10 |
None known |
tightvncUbuntu:26.10 |
All versions, plus listed versions 1:1.3.10-10build11:1.3.10-11 |
None known |
tightvncUbuntu:26.04:LTS |
All versions, plus listed versions 1:1.3.10-101:1.3.10-10build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-8287 is a critical vulnerability (CVSS 9.8) in Kaspersky Tightvnc, published October 29, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 19.5%, the 97th percentile. Fixed in tightvnc 1:1.3.9-9.1.
References
openwall.com/lists/oss-security/2018/12/10/5
lists.debian.org/debian-lts-announce/2019/12/msg00028.html
cert-portal.siemens.com/productcert/pdf/ssa-478893.pdf
us-cert.cisa.gov/ics/advisories/icsa-20-343-08
nvd.nist.gov/vuln/detail/CVE-2019-8287
github.com/advisories/GHSA-frvw-vf5g-vxwg
Show 12 moreShow less
security-tracker.debian.org/tracker/CVE-2019-8287
suse.com/support/update/announcement/2019/suse-su-201914235-1
bugzilla.suse.com/1155442
bugzilla.suse.com/1155452
bugzilla.suse.com/1155472
bugzilla.suse.com/1155476
suse.com/security/cve/CVE-2019-15678
suse.com/security/cve/CVE-2019-15679
suse.com/security/cve/CVE-2019-15680
suse.com/security/cve/CVE-2019-8287
ubuntu.com/security/CVE-2019-8287
cve.org/CVERecord?id=CVE-2019-8287