CVE-2019-9706
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service ...
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (use-after-free and daemon crash) because of a force_rescan_user error.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (use-after-free and daemon crash) because of a force_rescan_user error.
- Record
CVE-2019-9706- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 2.1 Low
AV:L/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (use-after-free and daemon crash) because of a force_rescan_user error.
- Record
CVE-2019-9706- Updated
- 2026-11-02
EUVDEUVD-2019-19072 No score
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (use-after-free and daemon crash) because of a force_rescan_user error.
- Record
EUVD-2019-19072- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vvgw-8mjp-fp2r
5.5
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service ...
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (use-after-free and daemon crash) because of a force_rescan_user error.
- Record
GHSA-vvgw-8mjp-fp2r- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSV
5.5
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (use-after-free and daemon crash) because of a force_rescan_user error.
- Record
CVE-2019-9706- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-9706
5.5
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (use-after-free and daemon crash) because of a force_rescan_user error.
- Record
DEBIAN-CVE-2019-9706- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-9706
5.5
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (use-after-free and daemon crash) because of a force_rescan_user error.
- Record
UBUNTU-CVE-2019-9706- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-5259-1 No score
cron vulnerabilities
It was discovered that the postinst maintainer script in Cron unsafely handled file permissions during package install or update operations. An attacker could possibly use this issue to perform a privilege escalation attack. (CVE-2017-9525)
Florian Weimer discovered that Cron incorrectly handled certain memory operations during crontab file creation. An attacker could possibly use this issue to cause a denial of service. (CVE-2019-9704)
It was discovered that Cron incorrectly handled user input during crontab file creation. An attacker could possibly use this issue to cause a denial of service. (CVE-2019-9705)
It was discovered that Cron contained a use-after-free vulnerability in its force_rescan_user function. An attacker could possibly use this issue to cause a denial of service. (CVE-2019-9706)
- Record
USN-5259-1- Updated
- 2026-11-02
OSVUSN-5259-2 No score
cron vulnerabilities
USN-5259-1 fixed several vulnerabilities in Cron. This update provides the corresponding update for Ubuntu 18.04 LTS.
Original advisory details:
It was discovered that the postinst maintainer script in Cron unsafely handled file permissions during package install or update operations. An attacker could possibly use this issue to perform a privilege escalation attack. (CVE-2017-9525)
Florian Weimer discovered that Cron incorrectly handled certain memory operations during crontab file creation. An attacker could possibly use this issue to cause a denial of service. (CVE-2019-9704)
It was discovered that Cron incorrectly handled user input during crontab file creation. An attacker could possibly use this issue to cause a denial of service. (CVE-2019-9705)
It was discovered that Cron contained a use-after-free vulnerability in its force_rescan_user function. An attacker could possibly use this issue to cause a denial of service. (CVE-2019-9706)
- Record
USN-5259-2- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cronDebian:12 |
before 3.0pl1-133 | 3.0pl1-133 |
cronDebian:13 |
before 3.0pl1-133 | 3.0pl1-133 |
cronDebian:14 |
before 3.0pl1-133 | 3.0pl1-133 |
cronDebian:8 From an advisory covering 4 CVEs |
before 3.0pl1-127+deb8u2, plus listed versions 3.0pl1-1273.0pl1-127+deb8u1 |
3.0pl1-127+deb8u2 |
cronDebian:9 From an advisory covering 4 CVEs |
before 3.0pl1-128+deb9u2, plus listed versions 3.0pl1-1283.0pl1-128+deb9u1 |
3.0pl1-128+deb9u2 |
cronUbuntu:14.04:LTS |
All versions, plus listed versions 3.0pl1-124ubuntu2 |
None known |
cronUbuntu:Pro:16.04:LTS |
before 3.0pl1-128ubuntu2+esm1, plus listed versions 3.0pl1-127ubuntu13.0pl1-128ubuntu13.0pl1-128ubuntu2 |
3.0pl1-128ubuntu2+esm1 |
cronUbuntu:18.04:LTS |
before 3.0pl1-128.1ubuntu1.1, plus listed versions 3.0pl1-128ubuntu53.0pl1-128.1ubuntu1 |
3.0pl1-128.1ubuntu1.1 |
cronUbuntu:Pro:16.04:LTS From an advisory covering 4 CVEs |
before 3.0pl1-128ubuntu2+esm1, plus listed versions 3.0pl1-127ubuntu13.0pl1-128ubuntu13.0pl1-128ubuntu2 |
3.0pl1-128ubuntu2+esm1 |
cronUbuntu:18.04:LTS From an advisory covering 4 CVEs |
before 3.0pl1-128.1ubuntu1.1, plus listed versions 3.0pl1-128ubuntu53.0pl1-128.1ubuntu1 |
3.0pl1-128.1ubuntu1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-9706 is a medium vulnerability (CVSS 5.5) in Debian Cron, published March 12, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 40th percentile. Fixed in cron 3.0pl1-133.
References
salsa.debian.org/debian/cron/commit/40791b93
bugs.debian.org/cgi-bin/bugreport.cgi?bug=809167
packages.qa.debian.org/c/cron/news/20190311T170403Z.html
lists.debian.org/debian-lts-announce/2019/03/msg00025.html
lists.debian.org/debian-lts-announce/2021/10/msg00029.html
nvd.nist.gov/vuln/detail/CVE-2019-9706
Show 9 moreShow less
github.com/advisories/GHSA-vvgw-8mjp-fp2r
security-tracker.debian.org/tracker/CVE-2019-9706
ubuntu.com/security/CVE-2019-9706
ubuntu.com/security/notices/USN-5259-1
ubuntu.com/security/notices/USN-5259-2
cve.org/CVERecord?id=CVE-2019-9706
ubuntu.com/security/CVE-2017-9525
ubuntu.com/security/CVE-2019-9704
ubuntu.com/security/CVE-2019-9705