Every CVE Search/ Get API key

CVE-2019-9898

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

9.8 CriticalFix available

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.94%Up 1.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Record
CVE-2019-9898
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-330
Updated
2026-11-02
CVE List No score

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Record
CVE-2019-9898
Updated
2026-11-02
EUVDEUVD-2019-19254 No score

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Record
EUVD-2019-19254
Updated
2026-11-03
GitHub AdvisoriesGHSA-8px9-pwgj-xj9f 9.8

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Record
GHSA-8px9-pwgj-xj9f
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-330
Updated
2026-11-02
OSVALPINE-CVE-2019-9898 9.8

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Record
ALPINE-CVE-2019-9898
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 9.8

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Record
CVE-2019-9898
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2019-9898 9.8

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Record
DEBIAN-CVE-2019-9898
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-9898 9.8

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

Record
UBUNTU-CVE-2019-9898
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0153 No score

Updated putty/filezilla/wxgtk packages fix security vulnerability

A remotely triggerable memory overwrite in RSA key exchange in PuTTY before 0.71 can occur before host key verification (CVE-2019-9894).

In PuTTY versions before 0.71 on Unix, a remotely triggerable buffer overflow exists in any kind of server-to-client forwarding (CVE-2019-9895).

Multiple denial-of-service attacks that can be triggered by writing to the terminal exist in PuTTY versions before 0.71 (CVE-2019-9897).

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71 (CVE-2019-9898).

The putty package has been updated to version 0.71 and the filezilla package has been updated and patched to fix these issues.

wxgtk has been updated to fix an assert when starting filezilla.

Record
MGASA-2019-0153
Updated
2026-11-02
OSVopenSUSE-SU-2019:1113-1 No score

Security update for putty

This update for putty fixes the following issues:

Update to new upstream release 0.71 [boo#1129633]

  • CVE-2019-9894: Fixed a remotely triggerable memory overwrite in RSA key exchange, which can occur before host key verification potential recycling of random numbers used in cryptography.
  • CVE-2019-9895: Fixed a remotely triggerable buffer overflow in any kind of server-to-client forwarding.
  • CVE-2019-9897: Fixed multiple denial-of-service attacks that can be triggered by writing to the terminal.
  • CVE-2019-9898: Fixed potential recycling of random numbers used in cryptography
  • CVE-2019-9896 (Windows only): Fixed hijacking by a malicious help file in the same directory as the executable
  • Major rewrite of the crypto code to remove cache and timing side channels.
Record
openSUSE-SU-2019:1113-1
Updated
2026-11-02
OSVopenSUSE-SU-2019:1123-1 No score

Security update for putty

This update for putty fixes the following issues:

Update to new upstream release 0.71 [boo#1129633]

  • CVE-2019-9894: Fixed a remotely triggerable memory overwrite in RSA key exchange, which can occur before host key verification potential recycling of random numbers used in cryptography.
  • CVE-2019-9895: Fixed a remotely triggerable buffer overflow in any kind of server-to-client forwarding.
  • CVE-2019-9897: Fixed multiple denial-of-service attacks that can be triggered by writing to the terminal.
  • CVE-2019-9898: Fixed potential recycling of random numbers used in cryptography
  • CVE-2019-9896 (Windows only): Fixed hijacking by a malicious help file in the same directory as the executable
  • Major rewrite of the crypto code to remove cache and timing side channels.

This update was imported from the openSUSE:Leap:15.0:Update update project.

Record
openSUSE-SU-2019:1123-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
putty
Alpine:v3.10
before 0.71-r0
0.71-r0
putty
Alpine:v3.11
before 0.71-r0
0.71-r0
putty
Alpine:v3.12
before 0.71-r0
0.71-r0
putty
Alpine:v3.13
before 0.71-r0
0.71-r0
putty
Alpine:v3.14
before 0.71-r0
0.71-r0
putty
Alpine:v3.15
before 0.71-r0
0.71-r0
putty
Alpine:v3.16
before 0.71-r0
0.71-r0
putty
Alpine:v3.17
before 0.71-r0
0.71-r0
putty
Alpine:v3.18
before 0.71-r0
0.71-r0
putty
Alpine:v3.19
before 0.71-r0
0.71-r0
Show 22 moreShow less
Affected packages
PackageAffectedFixed
putty
Alpine:v3.20
before 0.71-r0
0.71-r0
putty
Alpine:v3.21
before 0.71-r0
0.71-r0
putty
Alpine:v3.22
before 0.71-r0
0.71-r0
putty
Alpine:v3.23
before 0.71-r0
0.71-r0
putty
Alpine:v3.24
before 0.71-r0
0.71-r0
putty
Alpine:v3.6
before 0.71-r0
0.71-r0
putty
Alpine:v3.7
before 0.71-r0
0.71-r0
putty
Alpine:v3.8
before 0.71-r0
0.71-r0
putty
Alpine:v3.9
before 0.71-r0
0.71-r0
putty
Debian:12
before 0.70-6
0.70-6
putty
Debian:13
before 0.70-6
0.70-6
putty
Debian:14
before 0.70-6
0.70-6
putty
Debian:8
From an advisory covering 3 CVEs
before 0.63-10+deb8u2, plus listed versions
0.63-100.63-10+deb8u1
0.63-10+deb8u2
putty
Debian:9
From an advisory covering 4 CVEs
before 0.67-3+deb9u1, plus listed versions
0.67-3
0.67-3+deb9u1
putty
Mageia:6
From an advisory covering 4 CVEs
before 0.71-1.mga6
0.71-1.mga6
filezilla
Mageia:6
From an advisory covering 4 CVEs
before 3.31.0-1.mga6
3.31.0-1.mga6
libfilezilla
Mageia:6
From an advisory covering 4 CVEs
before 0.12.1-1.mga6
0.12.1-1.mga6
wxgtk
Mageia:6
From an advisory covering 4 CVEs
before 3.0.3.1-1.1.mga6
3.0.3.1-1.1.mga6
putty
Ubuntu:16.04:LTS
before 0.67-3+deb9u1build0.16.04.1, plus listed versions
0.65-20.66-10.66-20.66-30.66-40.67-10.67-20.67-3build0.16.04.1
0.67-3+deb9u1build0.16.04.1
putty
Ubuntu:18.04:LTS
All versions, plus listed versions
0.70-10.70-20.70-30.70-4
None known
putty
openSUSE:Leap 15.0
From an advisory covering 5 CVEs
before 0.71-lp150.9.1
0.71-lp150.9.1
putty
SUSE:Package Hub 15
From an advisory covering 5 CVEs
before 0.71-bp150.4.3.1
0.71-bp150.4.3.1

History

History
RecordedChangedSources
affected, facts
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-9898 is a critical vulnerability (CVSS 9.8) in Putty, published March 21, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.94%, the 90th percentile. Fixed in putty 0.71-r0.

References

Show 26 moreShow less
MoveEnter Open