Every CVE Search/ Get API key

CVE-2019-11476

Integer overflow in whoopsie results in out-of-bounds heap write

6.5 MediumFix available

An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-execution in the context of the whoopsie process.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.60%Down 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.5

Integer overflow in whoopsie results in out-of-bounds heap write

An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-execution in the context of the whoopsie process.

Record
CVE-2019-11476
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2019-3149 6.5

An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-execution in the context of the whoopsie process.

Record
EUVD-2019-3149
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-g2qp-pv3v-q7w2 7.8

An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0...

An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-execution in the context of the whoopsie process.

Record
GHSA-g2qp-pv3v-q7w2
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-190
Updated
2026-11-02
NVD 6.5

An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-execution in the context of the whoopsie process.

Record
CVE-2019-11476
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-190
Updated
2026-11-02
OSVUBUNTU-CVE-2019-11476 7.8

An integer overflow in whoopsie before versions 0.2.52.5ubuntu0.1, 0.2.62ubuntu0.1, 0.2.64ubuntu0.1, 0.2.66, results in an out-of-bounds write to a heap allocated buffer when processing large crash dumps. This results in a crash or possible code-execution in the context of the whoopsie process.

Record
UBUNTU-CVE-2019-11476
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
6.5 MediumCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Updated
2026-11-02
OSVUSN-4052-1 No score

whoopsie vulnerability

Kevin Backhouse discovered Whoopsie incorrectly handled very large crash reports. A local attacker could possibly use this issue to cause a denial of service or expose sensitive information.

Record
USN-4052-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
whoopsie
Ubuntu:16.04:LTS
before 0.2.52.5ubuntu0.1, plus listed versions
0.2.490.2.500.2.510.2.520.2.52.1
Show 4 moreShow less
0.2.52.20.2.52.30.2.52.40.2.52.5
0.2.52.5ubuntu0.1
whoopsie
Ubuntu:18.04:LTS
before 0.2.62ubuntu0.1, plus listed versions
0.2.580.2.590.2.59build10.2.600.2.62
0.2.62ubuntu0.1

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-11476 is a medium vulnerability (CVSS 6.5) in Canonical Whoopsie, published July 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.60%, the 48th percentile. Fixed in whoopsie 0.2.52.5ubuntu0.1.

References

MoveEnter Open