CVE-2019-12386
An issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php...
An issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php LocalPlay "add instance" functionality. The injected code is reflected in the instances menu. This vulnerability can be abused to force an admin to create a new privileged user whose credentials are known by the attacker.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
An issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php LocalPlay "add instance" functionality. The injected code is reflected in the instances menu. This vulnerability can be abused to force an admin to create a new privileged user whose credentials are known by the attacker.
- Record
CVE-2019-12386- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php LocalPlay "add instance" functionality. The injected code is reflected in the instances menu. This vulnerability can be abused to force an admin to create a new privileged user whose credentials are known by the attacker.
- Record
CVE-2019-12386- Updated
- 2026-11-02
EUVDEUVD-2019-4020 No score
An issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php LocalPlay "add instance" functionality. The injected code is reflected in the instances menu. This vulnerability can be abused to force an admin to create a new privileged user whose credentials are known by the attacker.
- Record
EUVD-2019-4020- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-367h-866v-prvm No score
An issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php...
An issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php LocalPlay "add instance" functionality. The injected code is reflected in the instances menu. This vulnerability can be abused to force an admin to create a new privileged user whose credentials are known by the attacker.
- Record
GHSA-367h-866v-prvm- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-12386
5.4
An issue was discovered in Ampache through 3.9.1. A stored XSS exists in the localplay.php LocalPlay "add instance" functionality. The injected code is reflected in the instances menu. This vulnerability can be abused to force an admin to create a new privileged user whose credentials are known by the attacker.
- Record
UBUNTU-CVE-2019-12386- CVSS 3.0
- 5.4 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUSN-4693-1 No score
ampache vulnerabilities
It was discovered that an SQL injection vulnerability exists in the Ampache search engine. Any user able to perform searches could dump any data contained in the database. An attacker could use this to disclose sensitive information. (CVE-2019-12385)
It was discovered that an XSS vulnerability in Ampache. An attacker could use this vulnerability to force an admin to create a new privileged user. (CVE-2019-12386)
- Record
USN-4693-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ampacheDebian:8 |
before 3.6-rzb2752+dfsg-5+deb8u1, plus listed versions 3.6-rzb2752+dfsg-5 |
3.6-rzb2752+dfsg-5+deb8u1 |
ampacheUbuntu:16.04:LTS |
before 3.6-rzb2779+dfsg-0ubuntu9.2, plus listed versions 3.6-rzb2779+dfsg-0ubuntu53.6-rzb2779+dfsg-0ubuntu63.6-rzb2779+dfsg-0ubuntu73.6-rzb2779+dfsg-0ubuntu83.6-rzb2779+dfsg-0ubuntu93.6-rzb2779+dfsg-0ubuntu9.1 |
3.6-rzb2779+dfsg-0ubuntu9.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-12386 is a medium vulnerability (CVSS 5.4) in Ampache, published August 22, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 57th percentile. Fixed in ampache 3.6-rzb2752+dfsg-5+deb8u1.
References
tarlogic.com/en/blog/vulnerabilities-in-ampache
lists.debian.org/debian-lts-announce/2019/11/msg00008.html
nvd.nist.gov/vuln/detail/CVE-2019-12386
github.com/advisories/GHSA-367h-866v-prvm
ubuntu.com/security/CVE-2019-12386
ubuntu.com/security/notices/USN-4693-1
cve.org/CVERecord?id=CVE-2019-12386
ubuntu.com/security/CVE-2019-12385