CVE-2019-12827
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2,...
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
- Record
CVE-2019-12827- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:N/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
- Record
CVE-2019-12827- Updated
- 2026-11-02
EUVDEUVD-2019-4407 No score
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
- Record
EUVD-2019-4407- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3x27-45gw-9p39
6.5
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2,...
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
- Record
GHSA-3x27-45gw-9p39- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119, CWE-787
- Updated
- 2026-11-02
OSVALPINE-CVE-2019-12827
6.5
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
- Record
ALPINE-CVE-2019-12827- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV
6.5
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
- Record
CVE-2019-12827- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-12827
6.5
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
- Record
DEBIAN-CVE-2019-12827- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-12827
6.5
Buffer overflow in res_pjsip_messaging in Digium Asterisk versions 13.21-cert3, 13.27.0, 15.7.2, 16.4.0 and earlier allows remote authenticated users to crash Asterisk by sending a specially crafted SIP MESSAGE message.
- Record
UBUNTU-CVE-2019-12827- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
asteriskAlpine:v3.10 |
13.0.0 up to 16.3.0-r2 | 16.3.0-r2 |
asteriskAlpine:v3.11 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.12 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.13 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.14 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.15 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.16 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.17 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.18 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.19 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
Show 11 moreShow less
| Package | Affected | Fixed |
|---|---|---|
asteriskAlpine:v3.20 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.21 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.22 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.23 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.24 |
13.0.0 up to 16.4.1-r0 | 16.4.1-r0 |
asteriskAlpine:v3.7 |
13.0.0 up to 15.6.2-r0 | 15.6.2-r0 |
asteriskAlpine:v3.8 |
13.0.0 up to 15.6.2-r0 | 15.6.2-r0 |
asteriskAlpine:v3.9 |
13.0.0 up to 15.7.4-r0 | 15.7.4-r0 |
asteriskDebian:14 |
before 1:16.2.1~dfsg-2, plus listed versions 0.1.11-30.1.11-3woody11:1.0.5-21:1.0.5-41:1.0.6-1 Show 45 moreShow less1:1.0.6-21:1.0.7-11:1.0.7.dfsg.1-11:1.0.7.dfsg.1-21:1.0.7.dfsg.1-2sarge11:1.0.7.dfsg.1-2sarge21:1.0.7.dfsg.1-2sarge31:1.0.7.dfsg.1-2sarge41:1.0.7.dfsg.1-2sarge51:1.0.7.dfsg.1-2sarge61:1.0.9.dfsg-11:1.0.9.dfsg-31:1.0.9.dfsg-41:1.0.9.dfsg-51:1.0.9.dfsg-61:1.2.0-beta1.dfsg-11:1.2.0-beta2.dfsg-11:1.2.0-beta2.dfsg-21:1.2.0-beta2.dfsg-31:1.2.0-rc1.dfsg-11:1.2.0-rc2.dfsg-11:1.2.0.dfsg-11:1.2.0.dfsg-21:1.2.0.dfsg-31:1.2.0.dfsg-41:1.2.0.dfsg-51:1.2.0.dfsg-61:1.2.1.dfsg-11:1.2.1.dfsg-21:1.2.1.dfsg-31:1.2.10.dfsg-11:1.2.10.dfsg-1bpo11:1.2.10.dfsg-21:1.2.10.dfsg-31:1.2.11.dfsg-11:1.2.12.1.dfsg-11:1.2.13~dfsg-11:1.2.13~dfsg-21:1.2.13~dfsg-2etch11:1.2.13~dfsg-2etch21:1.2.13~dfsg-2etch31:1.2.13~dfsg-2etch41:1.2.14~dfsg-11:1.2.14~dfsg-21:1.2.14~dfsg-3 |
1:16.2.1~dfsg-2 |
asteriskUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1:13.1.0~dfsg-1.1ubuntu31:13.1.0~dfsg-1.1ubuntu41:13.1.0~dfsg-1.1ubuntu4.11:13.1.0~dfsg-1.1ubuntu4.1+esm1 |
None known |
asteriskUbuntu:18.04:LTS |
All versions, plus listed versions 1:13.17.2~dfsg-1ubuntu11:13.17.2~dfsg-2ubuntu11:13.18.1~dfsg-1ubuntu11:13.18.3~dfsg-1ubuntu11:13.18.3~dfsg-1ubuntu21:13.18.3~dfsg-1ubuntu31:13.18.3~dfsg-1ubuntu4 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-12827 is a medium vulnerability (CVSS 6.5) in Digium Asterisk, published July 12, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.04%, the 90th percentile. Fixed in asterisk 16.3.0-r2.
References
issues.asterisk.org/jira/browse/ASTERISK-28447
downloads.digium.com/pub/security/AST-2019-002.html
nvd.nist.gov/vuln/detail/CVE-2019-12827
github.com/advisories/GHSA-3x27-45gw-9p39
security.alpinelinux.org/vuln/CVE-2019-12827
security-tracker.debian.org/tracker/CVE-2019-12827
ubuntu.com/security/CVE-2019-12827
cve.org/CVERecord?id=CVE-2019-12827
Left out here: 181 versions. The JSON record has them.