Every CVE Search/ Get API key

CVE-2019-13503

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

7.5 HighFix available

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.42%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

Record
CVE-2019-13503
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

Record
CVE-2019-13503
Updated
2026-11-02
EUVDEUVD-2019-4960 No score

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

Record
EUVD-2019-4960
Updated
2026-11-03
GitHub AdvisoriesGHSA-38p9-xg79-q3f9 7.5

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

Record
GHSA-38p9-xg79-q3f9
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 7.5

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

Record
CVE-2019-13503
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-13503 7.5

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.

Record
DEBIAN-CVE-2019-13503
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
swupdate
Debian:12
before 2021.04-1
2021.04-1
swupdate
Debian:13
before 2021.04-1
2021.04-1
swupdate
Debian:14
before 2021.04-1
2021.04-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-13503 is a high vulnerability (CVSS 7.5) in Cesanta Mongoose, published July 11, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in swupdate 2021.04-1.

References

MoveEnter Open