CVE-2019-14295
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote...
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
- Record
CVE-2019-14295- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-190
- Updated
- 2026-11-02
CVE List No score
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
- Record
CVE-2019-14295- Updated
- 2026-11-02
EUVDEUVD-2019-5522 No score
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
- Record
EUVD-2019-5522- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6m8h-vp4x-j6x4
5.5
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote...
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
- Record
GHSA-6m8h-vp4x-j6x4- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
5.5
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
- Record
CVE-2019-14295- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-14295
5.5
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
- Record
DEBIAN-CVE-2019-14295- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-14295
5.5
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory.
- Record
UBUNTU-CVE-2019-14295- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2020-0012 No score
Updated upx packages fix security vulnerability
The updated package fixes security vulnerabilities:
An Integer overflow in the getElfSections function in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an allocation of excessive memory. (CVE-2019-14295)
canUnpack in p_vmlinx.cpp in UPX 3.95 allows remote attackers to cause a denial of service (SEGV or buffer overflow, and application crash) or possibly have unspecified other impact via a crafted UPX packed file. (CVE-2019-14296)
- Record
MGASA-2020-0012- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
upx-uclDebian:13 |
before 3.95-2 | 3.95-2 |
upx-uclDebian:14 |
before 3.95-2 | 3.95-2 |
upxMageia:7 From an advisory covering 2 CVEs |
before 3.95-1.1.mga7 | 3.95-1.1.mga7 |
upx-uclUbuntu:16.04:LTS |
All versions, plus listed versions 3.91-1 |
None known |
upx-uclUbuntu:18.04:LTS |
All versions, plus listed versions 3.94-23.94-33.94-4 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-14295 is a medium vulnerability (CVSS 5.5) in Upx, published July 27, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.50%, the 74th percentile. Fixed in upx-ucl 3.95-2.
References
github.com/upx/upx/issues/286
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MOCJ43HTM45GZCAQ2FLEBDNBM76V22RG
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T52JATXV6NTPTMGXCRGT37H6KXERYNZN
nvd.nist.gov/vuln/detail/CVE-2019-14295
github.com/advisories/GHSA-6m8h-vp4x-j6x4
security-tracker.debian.org/tracker/CVE-2019-14295
Show 7 moreShow less
advisories.mageia.org/MGASA-2020-0012.html
bugs.mageia.org/show_bug.cgi?id=25935
lists.fedoraproject.org/archives/list/[email protected]/thread/MOCJ43HTM45GZCAQ2FLEBDNBM76V22RG
ubuntu.com/security/CVE-2019-14295
github.com/upx/upx/commit/58b122d97da1e02dfec24b10b6b8f56218b5622c
github.com/upx/upx/commit/6a53c0b3d499d62346a5c51034db543a4ef78ea3
cve.org/CVERecord?id=CVE-2019-14295