Every CVE Search/ Get API key

CVE-2019-14452

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary...

7.5 HighFix available

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

3.69%Up 1.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

Record
CVE-2019-14452
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

Record
CVE-2019-14452
Updated
2026-11-02
EUVDEUVD-2019-5641 No score

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

Record
EUVD-2019-5641
Updated
2026-11-03
GitHub AdvisoriesGHSA-4h5v-f3pf-4x55 7.5

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary...

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

Record
GHSA-4h5v-f3pf-4x55
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV 7.5

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

Record
CVE-2019-14452
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2019-14452 7.5

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

Record
DEBIAN-CVE-2019-14452
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2019-14452 7.5

Sigil before 0.9.16 is vulnerable to a directory traversal, allowing attackers to write arbitrary files via a ../ (dot dot slash) in a ZIP archive entry that is mishandled during extraction.

Record
UBUNTU-CVE-2019-14452
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2019-0249 No score

Updated sigil packages fix security vulnerability

Updated sigil package fixes security vulnerability:

Mike Salvatore discovered that Sigil mishandled certain malformed EPUB files. An attacker could use this vulnerability to write arbitrary files to the filesystem (CVE-2019-14452).

Record
MGASA-2019-0249
Updated
2026-11-02
OSVUSN-4085-1 No score

Sigil vulnerability

Mike Salvatore discovered that Sigil mishandled certain malformed EPUB files. An attacker could use this vulnerability to write arbitrary files to the filesystem.

Record
USN-4085-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sigil
Debian:12
before 0.9.16+dfsg-1
0.9.16+dfsg-1
sigil
Debian:13
before 0.9.16+dfsg-1
0.9.16+dfsg-1
sigil
Debian:14
before 0.9.16+dfsg-1
0.9.16+dfsg-1
sigil
Mageia:6
before 0.9.16-1.mga6
0.9.16-1.mga6
sigil
Mageia:7
before 0.9.16-1.mga7
0.9.16-1.mga7
sigil
Ubuntu:16.04:LTS
before 0.9.5+dfsg-0ubuntu1+esm1, plus listed versions
0.8.7+dfsg-30.9.2+dfsg+dfsg-20.9.4+dfsg-0ubuntu10.9.5+dfsg-0ubuntu1
0.9.5+dfsg-0ubuntu1+esm1
sigil
Ubuntu:18.04:LTS
before 0.9.9+dfsg-1ubuntu0.1~esm1, plus listed versions
0.9.8+dfsg-2build20.9.9+dfsg-1
0.9.9+dfsg-1ubuntu0.1~esm1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-14452 is a high vulnerability (CVSS 7.5) in Sigil-ebook Sigil, published July 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.69%, the 89th percentile. Fixed in sigil 0.9.16+dfsg-1.

References

Show 10 moreShow less
MoveEnter Open