Every CVE Search/ Get API key

CVE-2019-14697

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the...

9.8 CriticalFix available

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.53%Up 1.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Record
CVE-2019-14697
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Record
CVE-2019-14697
Updated
2026-11-02
EUVDEUVD-2019-5847 No score

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Record
EUVD-2019-5847
Updated
2026-11-03
GitHub AdvisoriesGHSA-x5qg-pw5v-r37v 9.8

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the...

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Record
GHSA-x5qg-pw5v-r37v
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSVALPINE-CVE-2019-14697 9.8

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Record
ALPINE-CVE-2019-14697
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBELL-CVE-2019-14697 9.8

CVE-2019-14697 does not affect BellSoft software

Record
BELL-CVE-2019-14697
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 5 moreShow less
OSV 9.8

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Record
CVE-2019-14697
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-14697 9.8

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Record
DEBIAN-CVE-2019-14697
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-14697 9.8

musl libc through 1.1.23 has an x87 floating-point stack adjustment imbalance, related to the math/i386/ directory. In some cases, use of this library could introduce out-of-bounds writes that are not present in an application's source code.

Record
UBUNTU-CVE-2019-14697
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:10761-1 No score

flannel-0.14.0-1.2 on GA media

These are all security issues fixed in the flannel-0.14.0-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10761-1
Updated
2026-11-02
OSVUSN-5990-1 No score

musl vulnerabilities

It was discovered that musl did not handle certain i386 math functions properly. An attacker could use this vulnerability to cause a denial of service (crash) or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, and Ubuntu 18.04 LTS. (CVE-2019-14697)

It was discovered that musl did not handle wide-character conversion properly. A remote attacker could use this vulnerability to cause resource consumption (infinite loop), denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2020-28928)

Record
USN-5990-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
musl
Alpine:v3.10
0.9.12 up to 1.1.22-r3
1.1.22-r3
musl
Alpine:v3.11
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.12
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.13
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.14
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.15
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.16
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.17
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.18
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.19
0.9.12 up to 1.1.23-r2
1.1.23-r2
Show 19 moreShow less
Affected packages
PackageAffectedFixed
musl
Alpine:v3.20
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.21
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.22
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.23
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.24
0.9.12 up to 1.1.23-r2
1.1.23-r2
musl
Alpine:v3.7
0.9.12 up to 1.1.18-r4
1.1.18-r4
musl
Alpine:v3.8
0.9.12 up to 1.1.19-r11
1.1.19-r11
musl
Alpine:v3.9
0.9.12 up to 1.1.20-r5
1.1.20-r5
musl
Debian:12
before 1.1.23-2
1.1.23-2
musl
Debian:13
before 1.1.23-2
1.1.23-2
musl
Debian:14
before 1.1.23-2
1.1.23-2
musl
Ubuntu:Pro:14.04:LTS
before 0.9.15-1ubuntu0.1~esm2, plus listed versions
0.9.14-20.9.14-2ubuntu10.9.15-10.9.15-1ubuntu0.1~esm1
0.9.15-1ubuntu0.1~esm2
musl
Ubuntu:Pro:16.04:LTS
before 1.1.9-1ubuntu0.1~esm3, plus listed versions
1.1.9-11.1.9-1ubuntu0.1~esm2
1.1.9-1ubuntu0.1~esm3
musl
Ubuntu:Pro:18.04:LTS
before 1.1.19-1ubuntu0.1~esm1, plus listed versions
1.1.16-31.1.18-11.1.19-1
1.1.19-1ubuntu0.1~esm1
musl
Ubuntu:Pro:14.04:LTS
From an advisory covering 2 CVEs
before 0.9.15-1ubuntu0.1~esm2, plus listed versions
0.9.14-20.9.14-2ubuntu10.9.15-10.9.15-1ubuntu0.1~esm1
0.9.15-1ubuntu0.1~esm2
musl
Ubuntu:Pro:16.04:LTS
From an advisory covering 2 CVEs
before 1.1.9-1ubuntu0.1~esm3, plus listed versions
1.1.9-11.1.9-1ubuntu0.1~esm2
1.1.9-1ubuntu0.1~esm3
musl
Ubuntu:Pro:18.04:LTS
From an advisory covering 2 CVEs
before 1.1.19-1ubuntu0.1~esm1, plus listed versions
1.1.16-31.1.18-11.1.19-1
1.1.19-1ubuntu0.1~esm1
musl
Ubuntu:Pro:20.04:LTS
From an advisory covering 2 CVEs
before 1.1.24-1ubuntu0.1~esm1, plus listed versions
1.1.23-2build11.1.24-1
1.1.24-1ubuntu0.1~esm1
flannel
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 0.14.0-1.2
0.14.0-1.2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-14697 is a critical vulnerability (CVSS 9.8) in Musl-libc Musl, published August 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.53%, the 84th percentile. Fixed in musl 1.1.22-r3.

References

Show 13 moreShow less
MoveEnter Open