Every CVE Search/ Get API key

CVE-2019-15161

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a...

5.3 MediumFix available

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

2.76%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.3

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

Record
CVE-2019-15161
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-131
Updated
2026-11-02
CVE List No score

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

Record
CVE-2019-15161
Updated
2026-11-02
EUVDEUVD-2019-6217 No score

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

Record
EUVD-2019-6217
Updated
2026-11-03
GitHub AdvisoriesGHSA-mpx8-phwc-v8wq No score

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a...

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

Record
GHSA-mpx8-phwc-v8wq
Updated
2026-11-02
OSVALPINE-CVE-2019-15161 5.3

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

Record
ALPINE-CVE-2019-15161
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVBELL-CVE-2019-15161 5.3

CVE-2019-15161 does not affect BellSoft software

Record
BELL-CVE-2019-15161
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
Show 4 moreShow less
OSV 5.3

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

Record
CVE-2019-15161
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2019-15161 5.3

rpcapd/daemon.c in libpcap before 1.9.1 mishandles certain length values because of reuse of a variable. This may open up an attack vector involving extra data at the end of a request.

Record
DEBIAN-CVE-2019-15161
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVMGASA-2019-0297 No score

Updated libpcap and tcpdump packages fix security vulnerabilities

Updated libpcap and tcpdump packages fix security vulnerabilities:

The libpcap packages have been updated to versions 1.9.1 and tcpdump to 4.9.3, respectively, fixing several buffer overread and overflow issues.

Record
MGASA-2019-0297
Updated
2026-11-02
OSVopenSUSE-SU-2024:10969-1 No score

libpcap-devel-1.10.1-1.2 on GA media

These are all security issues fixed in the libpcap-devel-1.10.1-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10969-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libpcap
Alpine:v3.10
before 1.1.1-r0
1.1.1-r0
libpcap
Alpine:v3.12
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.13
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.14
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.15
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.16
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.17
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.18
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.19
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.20
before 1.9.1-r0
1.9.1-r0
Show 9 moreShow less
Affected packages
PackageAffectedFixed
libpcap
Alpine:v3.21
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.22
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.23
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.24
before 1.9.1-r0
1.9.1-r0
libpcap
Debian:12
before 1.9.1-1
1.9.1-1
libpcap
Debian:13
before 1.9.1-1
1.9.1-1
libpcap
Debian:14
before 1.9.1-1
1.9.1-1
libpcap
Mageia:7
From an advisory covering 32 CVEs
before 1.9.1-1.mga7
1.9.1-1.mga7
tcpdump
Mageia:7
From an advisory covering 32 CVEs
before 4.9.3-1.mga7
4.9.3-1.mga7

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-15161 is a medium vulnerability (CVSS 5.3) in Tcpdump Libpcap, published October 3, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.76%, the 86th percentile. Fixed in libpcap 1.1.1-r0.

References

Show 21 moreShow less
MoveEnter Open